Bug 38576 - page layout is confused in the presence of repeating rows
Summary: page layout is confused in the presence of repeating rows
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-22 11:12 UTC by Andreas J Guelzow
Modified: 2012-08-31 10:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample file (11.14 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-06-22 11:12 UTC, Andreas J Guelzow
Details
Screenshots of print preview. (60.82 KB, application/x-zip)
2012-08-14 19:16 UTC, Kohei Yoshida
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas J Guelzow 2011-06-22 11:12:52 UTC
Created attachment 48298 [details]
sample file

The attached file was created in LibreOffice Calc 3.3.2. It has a long first column of numbers with cells A3 and A4 containing strings. Rows 3 and 4 are defined as repeating.

Looking at the page preview I would have expected rows 3 and 4 to appear on every page. [There could an argument being made that on the first page only rows 1 and 2 are shown, as it currently happens. THis is not my issue.)

Page 2 shows only rows 3 and 4, I would have expected to also see some of the next rows.

Page 3 shows all rows from 3 onwards. As a consequence the numbers run of the bottom of the page. I would have expected correct pagination.
Comment 1 Andreas J Guelzow 2011-06-22 11:24:26 UTC
I just noticed that when I reopen the attached file the page layout is correct. So the problem only occurs when the file has just been created:

new LoCalc
enter 1...150 in A1 to A150
enter "header" in A3
enter "header2" in A4
select rows 3 and 4
select Format->PrintRanges->Define
select Format->PrintRanges->Edit
click in "Rows to repeat" 
draq A3 to A4, in the "Rows to repeat" entry $3:$4 appears
delete the content of the "Print Range" box
ok
page preview
Comment 2 Björn Michaelsen 2011-12-23 12:27:10 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Andreas J Guelzow 2011-12-23 13:04:29 UTC
I will not waste my time with checking whether this is still true in some recent unreleased version. I filed this report as a service to the LibreOffice user community. I am of course _not_ using LO myself. So if you don't care about these bugs, feel free to close this report.
Comment 4 Florian Reisinger 2012-08-14 14:02:33 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:03:30 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:08:05 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:10:10 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 Michael Meeks 2012-08-14 18:59:57 UTC
Loading the sample file shows a clearly horribly confused, inaccurately empty page - that's rather unfortunate. Only if I close Page Preview and re-open it do I see the correct document contents.
Comment 9 Kohei Yoshida 2012-08-14 19:07:23 UTC
(In reply to comment #8)
> Loading the sample file shows a clearly horribly confused, inaccurately empty
> page - that's rather unfortunate. Only if I close Page Preview and re-open it
> do I see the correct document contents.

That's a separate issue btw, and was already addressed in 3.6 by disallowing save from print preview window.

The heart of this bug is as described in Comment 1.
Comment 10 Kohei Yoshida 2012-08-14 19:15:41 UTC
And I can no longer reproduce the bug originally reported, using my 3.6.0 build.  I'll attach my print preview pages so that Andreas can confirm or deny.
Comment 11 Kohei Yoshida 2012-08-14 19:16:27 UTC
Created attachment 65562 [details]
Screenshots of print preview.

Screenshots of print preview.
Comment 12 Andreas J Guelzow 2012-08-14 19:30:56 UTC
@Kohei,

those preview pages look like I would expect (ie. correctly paginated). Assuming that you created them as described in comment #1 (since the attached file as mentioned in comment #1 always results in correct pagination) you could consider this bug fixed.

Note that in LibreOffice 3.5.4.2 Build ID: 350m1(Build:2) the print preview shows no pages at all. (This seems to have to do with:
"delete the content of the "Print Range" box"
but that might be expected.)
Comment 13 Kohei Yoshida 2012-08-14 19:59:10 UTC
(In reply to comment #12)
> @Kohei,
> 
> those preview pages look like I would expect (ie. correctly paginated).
> Assuming that you created them as described in comment #1 (since the attached
> file as mentioned in comment #1 always results in correct pagination) you could
> consider this bug fixed.
> 
> Note that in LibreOffice 3.5.4.2 Build ID: 350m1(Build:2) the print preview
> shows no pages at all.

That may be caused by the "save from print preview" bug that Michael described.  If you save your document while in print preview mode, it skips saving the page selection information so that, when you re-open that document, which Calc opens directly in print preview mode and you get no pages.

If this is the case, exit the print preview mode and go back into print preview again.  In 3.6.0 and newer versions you can no longer save the document while in print preview mode to prevent this.  But unfortunately we can't fix those existing docs saved this way using an older version (since the damage has already been done).
Comment 14 Andreas J Guelzow 2012-08-14 20:04:26 UTC
@Kohei,

there is no saving involved.

In LibreOffice 3.5.4.2 Build ID: 350m1(Build:2) if I create the file as described in comment #1 (without any saving) and ask for the print preview, I get an empty preview. But this is clearly related to the interpretation of "no print range" meaning to print nothing.

So that is probably no bug and simply a GUI behaviour change from 3.3.2 to 3.5.4.2

The main thing is that even in 3.5.4.2 the original bug reported here appears to be fixed.
Comment 15 Kohei Yoshida 2012-08-14 20:18:47 UTC
(In reply to comment #14)
> @Kohei,
> 
> there is no saving involved.
> 
> In LibreOffice 3.5.4.2 Build ID: 350m1(Build:2) if I create the file as
> described in comment #1 (without any saving) and ask for the print preview, I
> get an empty preview. But this is clearly related to the interpretation of "no
> print range" meaning to print nothing.

Yes.  That's my understanding as well.

> So that is probably no bug and simply a GUI behaviour change from 3.3.2 to
> 3.5.4.2
> 
> The main thing is that even in 3.5.4.2 the original bug reported here appears
> to be fixed.

Thanks for the confirmation, Andreas.  I'll close this bug.