Bug Hunting Session
Bug 38639 - DOCX: section change with different header/footer settings not regarded
Summary: DOCX: section change with different header/footer settings not regarded
Status: RESOLVED DUPLICATE of bug 93640
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-24 05:37 UTC by Gerhard T.
Modified: 2016-06-23 09:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
docx file to reproduce the problem (80.06 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-06-24 05:37 UTC, Gerhard T.
Details
pdf exported from Word 2010 (220.94 KB, application/pdf)
2012-04-26 05:34 UTC, Niklas Johansson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard T. 2011-06-24 05:37:05 UTC
DOCX documents with footers in different sections cannot be viewed correctly.
The footer of the first page is used for the whole document.
Comment 1 Gerhard T. 2011-06-24 05:37:55 UTC
Created attachment 48379 [details]
docx file to reproduce the problem
Comment 2 Björn Michaelsen 2011-12-23 12:23:50 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Gerhard T. 2011-12-30 00:15:58 UTC
The problem is reproducible with LibreOffice 3.5 Beta2.
Comment 4 Niklas Johansson 2012-04-26 05:33:16 UTC
Reproduced with LibreOffice 3.5.2. Some extra info:

The footers in page 2, 3, 4 gets exported into a page style called Converted1. The problem is it never gets used.

The first page has a continuous section break followed by a simple page break. As far as I know Writer don't really have a equivalent for the continuous section break. If a continuous section break appears in a document the next page might include a new header/footer which may or may not be linked with the previous header. If it would have been a "next page section break" then every thing would have worked as expected. 

I suppose this will be hard to fix without introducing an equivalent to continuous section break. 

I will attach a PDF created by Word 2010 so people without Word can see how it is supposed to look.


PS. I did a short test converting this file to odt using Word 2010, let's say that it gave some interesting results.
Comment 5 Niklas Johansson 2012-04-26 05:34:41 UTC
Created attachment 60612 [details]
pdf exported from Word 2010
Comment 6 Niklas Johansson 2013-08-13 15:00:07 UTC
It seems this is still an issue in LibreOffice 4.0.4.
Comment 7 vulcain 2014-01-31 09:33:10 UTC
Still here in LibreOffice 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71 on Ubuntu 12.04.4 x86_64
Comment 8 Joel Madero 2015-05-02 15:43:33 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 9 Niklas Johansson 2015-05-04 13:10:29 UTC
Still valid in LibreOffice 4.4.3 rc 2. Also tested with master and valid there as well.

Note that there is a a continuous section break on the first page of the document.
Comment 10 Justin L 2016-06-23 09:50:16 UTC
fixed in 5.1.4 - Duplicate of bug 93640

bibisected (linux daily) and assume the fix came from
   author	Luke Deller <luke@deller.id.au>	2016-01-03 12:12:56 (GMT)
   tdf#93640	Fix import of linked left page header/footer

*** This bug has been marked as a duplicate of bug 93640 ***