Bug 38679 - Graphical objects corrupted on saving
Summary: Graphical objects corrupted on saving
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-25 14:11 UTC by sergio.callegari
Modified: 2016-02-16 15:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF file to open and try to save as odg (315.61 KB, application/pdf)
2011-06-25 14:11 UTC, sergio.callegari
Details
Result of opening pdf file and saving it (176.23 KB, application/vnd.oasis.opendocument.graphics)
2011-06-25 14:12 UTC, sergio.callegari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2011-06-25 14:11:37 UTC
Created attachment 48408 [details]
PDF file to open and try to save as odg

I am experiencing an issue with drawings imported from pdf with the PDF import extension.

To reproduce 

1) I open the pdf file and it displays just fine
2) I save is as an odg or inside an odp file
3) I open the odg or odp file

Expected results

The image displayed at 3 and the image displayed as 1 are the same

Achieved results

Image displayed at 3 is completely messed up.

Since at 1, the image is displayed correctly, I assume that as long as the drawing graphical data is in memory, it is correct. This is confirmed by the fact that if the drawing is converted to metafile it converts and saves just fine. It is on saving in the opendocument format that the graphic object gets corrupted!

Seems rather serious to me if you cannot trust the application to save in a conforming manner what it has on display.
Comment 1 sergio.callegari 2011-06-25 14:12:11 UTC
Created attachment 48409 [details]
Result of opening pdf file and saving it
Comment 2 Björn Michaelsen 2011-12-23 12:22:37 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 sergio.callegari 2011-12-27 03:47:17 UTC
Confirmed on 3.5.0 beta2
Comment 4 A (Andy) 2013-12-28 15:56:51 UTC
@Fridrich: Could this maybe be something for you?

reproducible with LO 4.1.4.2 (Win8): the import in DRAW is mostly fine, but a very few small issues are still there (see the legend)
Comment 5 QA Administrators 2015-04-19 03:21:19 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 6 sergio.callegari 2015-04-25 10:09:40 UTC
Bug seems fixed in 4.3.3 as shipped by ubuntu.

Unfortunately, I will not be able to test with 4.4 since I have moved back to using distro provided package after issues with how TDF has started packaging LibO for debian derivatives beginning at 4.4.

In any case I would mark this as closed.
Comment 7 sergio.callegari 2016-02-16 14:35:52 UTC
Bug is fixed in recent LibO
Comment 8 Timur 2016-02-16 15:53:23 UTC
If a specific commit/fix is not known, then it's not Fixed, but WorksForMe.