Bug Hunting Session
Bug 38698 - [UI] Zoom slider vanishes when adding new slide
Summary: [UI] Zoom slider vanishes when adding new slide
Status: RESOLVED DUPLICATE of bug 33848
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.1 RC1
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-26 18:09 UTC by Stefan Knorr (astron)
Modified: 2011-06-28 05:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2011-06-26 18:09:21 UTC
In Impress and Draw the zoom slider in the status bar vanishes sometimes. Sometimes it appears again, sometimes not...

There seem to be multiple ways to make the slider vanish, but this one works reliably:

* start Impress or Draw
* right-click on left sidebar
* click New Slide, respectively, New Page
Comment 1 Jeffrey 2011-06-27 07:43:01 UTC
Reproduced on LibreOffice 3.4 340ml(Build:12) on KDE OpenSuse. Zoom slider is very fragile. I couldn't even see it at first. There seems to be many ways to disable/making it disappear without knowing, such as inserting text into one of the pre-made text boxes on the slides.
Comment 2 Stefan Knorr (astron) 2011-06-27 08:13:47 UTC
A few more things:
#1 Changed platform/OS to All, because I now saw this on Windows (x86), too
#2 This is reproducible with LibO 3.3.1 and 3.4.1rc2
#3 When the zoom slider isn't visible clicking the (now) empty space also doesn't do anything.
Comment 3 Rainer Bielefeld Retired 2011-06-27 09:48:49 UTC
Effect from original report 100% Reproducible with "LibreOffice 3.4.1RC1 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]" for DRAW and Impress. But it's not a bug, but a user error, please see "33848 - UI problem in presenter: ZoomSlider sometimes disappears".

I also was able to reproduce Jeffrey's observation sometimes after some hopping between slide pane, text field borders and text field contents the Zoom Slider disappeared although focus was "somehow" on document slide, but I am sure that that is related.

Same effects with OOo 3.4-dev and 3.1.1

@reporter / Jeffrey:
Please feel free to reopen this Bug if you find evidence that we have an independent issue here.

*** This bug has been marked as a duplicate of bug 33848 ***
Comment 4 Stefan Knorr (astron) 2011-06-27 10:27:32 UTC
I hope someone else will comment and maybe reopen, but to me the behaviour seems a bit erratic. I can sort of understand that the zoom slider isn't available in the Slide Sorter view (the slide sorter could however also show slides at different zoom levels), but it definitely should be available when using the Slides sidebar -- to zoom the slides in the main window (the similar look of sorter and sidebar makes me think the code is the same [1]).

The rest of the bug are UI problems:
* the Zoom slider takes a little time to vanish after a sidebar action (might get better with time but potentially no easy fix)
* the two bars to the left and right sides are still there making the status bar look broken
* when using the context menu of the sidebar, the Zoom slider only vanishes after selecting an element of the menu (it should vanish immediately after right-clicking the area.


[1] The behaviour of the two elements as regards the Zoom differ already: the slide sorter view doesn't even show the zoom percentage, whereas this is still displayed when the user is using the sidebar.
Comment 5 Rainer Bielefeld Retired 2011-06-27 11:14:40 UTC
@Aaron:
You should better comment in Bug 33848, here your comments will not be read!
Only if you found evidence that this is an independent bug comments here concerning those considerations will be useful.

Why did you modify OS-Picker? Don't you believe me that I reproduced the problem with WIN? And do you really believe that problem only is visible on PC with 64 bit processor? Please do not touch pickers if you do not know what they are for, but add information in your comment!

Thank you for your attention

Rainer
Comment 6 Jeffrey 2011-06-28 01:43:45 UTC
Rainer, I think the problem has more to do with the zoom slider's code than clicking on text boxes or making new slides. Some group or types of functions/objects are altering the visibility of the slider, and I think that if this problem is fixed for the slider, then it should not be a problem elsewhere. (ie I think fixing the problem with the slider/source is easier than fixing at all the other places.) 

So I think that leaving this / its duplicate as the bug is fine without opening a new one. If the slider can be fixed for when creating new slides while others still persist then maybe it will be a good time to open the text box one.
Comment 7 Stefan Knorr (astron) 2011-06-28 05:36:42 UTC
@ Rainer:
Sorry, if I accidentally (I honestly have no idea how this could happen [1]) reset the OS/platform. I didn't mean to, no ill will.

I'll copy my comment over to the original bug later and change the title, is that fine with you?



[1] The closest thing to an explanation would be that I tried to set both to All (as I reported the bug initially for x86-64 and Linux), but they were already set to All, so I could have changed them the way I thought they were. But, really I don't remember being this absent-minded.