Bug Hunting Session
Bug 39093 - "Save as" not possible on the network
Summary: "Save as" not possible on the network
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) other
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 34605 40206 40567 42130 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-09 07:04 UTC by lool.lauris@gmail.com
Modified: 2013-05-07 10:05 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lool.lauris@gmail.com 2011-07-09 07:04:23 UTC
Hi,

I have a Windows 7 desktop PC where there is documents LibreOffice.
I have a laptop which is under Ubuntu 11.04 64 bits.

I'm able to connect the Windows computer through a wifi network. I open a LibreOffice document to use it as a model. 
I choose "Save as" to give a new name and create a new file in the same directory but I get the following error message :

Erreur lors de l'enregistrement du document xxxx:
Erreur générale.
Erreur d'entrée/sortie générale.

So in english :

Error during the recording of the document xxxx:
General error.
General Input/Output error.

I precise that I have this trouble only with LibreOffice documents. The "Save as" works perfectly with other type of file (txt, jpg, and so on).

Bye,
lool
Comment 1 Caolán McNamara 2011-07-09 07:22:12 UTC
"I have a Windows 7 desktop PC where there is documents LibreOffice.
I have a laptop which is under Ubuntu 11.04 64 bits."

On which computer do you have the problem. On the windows computer saving to a samba file share exported from the Linux box ?, or on the linux computer saving to a samba file shared exported from the Windows box ?
Comment 2 lool.lauris@gmail.com 2011-07-09 16:54:23 UTC
(In reply to comment #1)

> On which computer do you have the problem. On the windows computer saving to a
> samba file share exported from the Linux box ?, or on the linux computer saving
> to a samba file shared exported from the Windows box ?

Sorry for the lack of precision.
The problem is on the Linux laptop. In fact the shared directories are on the Windows desktop computer, a kind of personal data base. And the most part of the time I work with my laptop under Ubuntu that I used to access to the files stored on the Windows computer.
Comment 3 tester8 2011-07-10 09:33:06 UTC
NOT Reproduced with

LO 3.4.1 (OOO340m1 (Build:101))
Ubuntu 10.04.2 x86
Linux 2.6.32-32-generic Russian UI

samba 2:3.4.7~dfsg-1ubuntu3.6

Windows Vista SP1
Comment 4 Michel BAUDLET 2011-10-08 10:46:27 UTC
Hello,
I observe the same bug on the network of my primary school where, exceptionnaly this year I'm in charge of ICT teaching.

- 8 computers on Windows XP pro (one is the "server")
- 5 on Ubuntu 11.04 updated

I have to acceed via : /<user>/.gvfs/<directory shortcut> on <server>.

I discovered this testing with Ooo4Kids which needs to search in upper directory.

Precision :

Samba package, itself, is not installed on the four computers where I'm sure I have the problem.
Only, basic packages, are loaded :
- Samba-common
- Samba-common-bin
- python-smbc
- smbclient
- libsmbclient

On the fifth PC with Ubuntu, I'm sure I have loaded the Samba package, but I'm not sure I had this problem. I shall confirm that Monday.
Comment 5 Michel BAUDLET 2011-10-10 02:05:46 UTC
Hello,

All computers I have in the ICT classroom are 32 bits.

Ok! I tested the computer with Samba package : it's the same thing.

On each, I've created :

- a network shortcut (connect to a server) in shortcuts menu (Ubuntu classic)
- a shortcut on the desktop for students.

( They open my originals then "save as" into there folder )
Comment 6 Alex Thurgood 2011-10-23 10:01:20 UTC
*** Bug 42130 has been marked as a duplicate of this bug. ***
Comment 7 Alex Thurgood 2011-10-23 10:02:17 UTC
*** Bug 40206 has been marked as a duplicate of this bug. ***
Comment 8 Alex Thurgood 2011-10-23 10:03:02 UTC
*** Bug 40567 has been marked as a duplicate of this bug. ***
Comment 9 Alex Thurgood 2011-10-23 10:04:02 UTC
*** Bug 34605 has been marked as a duplicate of this bug. ***
Comment 10 Phil Wolff 2011-10-26 12:02:36 UTC
I will note that this bug still exists in LibO 3.4.3 build 302 on Ubuntu 11.10 (x86-Intel, Linux 3.0.0.12, samba 2:3.5.11~dfsg-1ubuntu2), all of which are current.

The network folder in my case is a read-write-shared folder on a Windows XP desktop machine. Other Ubuntu apps (specifically file browser Nautilus and text editor gedit) can read, write, modify, create, and delete files at will in this folder. LibO (Writer, Draw, and Calc for sure, haven't tried the others) cannot Save or Save As to the folder, generating the remarkably uninformative error message indicated in the original bug report, nor can they read an existing file from the folder, exiting silently (!!!).
Comment 11 Winfried Donkers 2011-10-31 23:58:08 UTC
problem does NOT occur with Windows XP client, Libo 3.4.3 and openSUSe 11.4 with samba shares.
(These error messages do occur when trying to save as to an existing file for which the user has only read rights. An error message should occur, but the message is not clear to the user.)
Comment 12 Lionel Elie Mamane 2011-11-21 05:50:39 UTC
Cannot reproduce with LO 3.4.4 (Debian package amd64) saving to share on Windows 2008R2 server.

Cannot reproduce with master (self-compiled running on Debian GNU/Linux amd64) saving to share on Windows 2008R2 server.

Cannot reproduce with LO 3.4.4 (Debian package amd64) saving to share on Windows 7 Professional desktop.

All mounts done with CIFS filesystem, *not* smbfs.
Comment 13 Lionel Elie Mamane 2011-11-22 14:43:31 UTC
The Ubuntu bug contains an interesting information: mounting the cifs share with option "nobrl" works around this. Here's the description of that option:

       nobrl
           Do not send byte range lock requests to the server. This is
           necessary for certain applications that break with cifs style
           mandatory byte range locks (and most cifs servers do not yet
           support requesting advisory byte range locks).

I'm not sure whether LibreOffice can avoid sending those "byte range lock requests" without that option or not. E.g. it might come from LibreOffice's use of fcntl(F_SETLK/F_SETLKW) or maybe even flock(). I'm not sure why LO would use file locking, though.
Comment 14 Björn Michaelsen 2011-12-23 12:25:57 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 15 leighman 2011-12-28 02:31:27 UTC
Confirmed on launchpad
Comment 16 Björn Michaelsen 2012-02-15 12:43:18 UTC
removing launchpad issue, thats a vendor issue.
Comment 17 Oliver Joos 2012-02-15 15:00:01 UTC
Thanks Björn, this is good news! (It seems to be fixed in libreoffice 1:3.5.0~beta2-2, see https://launchpad.net/bugs/792622 or directly http://anonscm.debian.org/gitweb/?p=pkg-openoffice/libreoffice.git;a=commit;h=cc27f8c6002aea8af30799f9b4d11eba445f9486 )
Comment 18 Michael Meeks 2013-05-07 10:05:54 UTC
seems to be fixed for more than a year => marking fixed; I guess gvfs solved the issue for you :-)