Download it now!
Bug 39449 - Tools->Customize->Events / Assigned Macros don't work
Summary: Tools->Customize->Events / Assigned Macros don't work
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: bibisected35 bibisected35older
Keywords: regression
: 39043 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-21 09:03 UTC by Thomas Foerster
Modified: 2015-05-25 12:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Foerster 2011-07-21 09:03:42 UTC
Win XP SP3 (32bit) LibO 3.4.1 release

Assigned (Tools->Customize->Events) macros don't work. Tested with "Activate Document" and "Print Document". May be other events too.

Try this i.e.:

Sub HelloWorld
  msgbox "Hello World!"
End Sub

In OO.3.3.0 "Activate Document" worked - but not "Print Document" (may be others). The actual LibO Master LibO-dev 3.5 does the same as OO3.3.0: "Activate Document" is working now again, but NOT "Print Document" (and may be others)...

11-Jul-2011 17:34
http://dev-builds.libreoffice.org/daily/Provo_Windows_x86_Tinderbox/master/current/

See also:
https://bugs.freedesktop.org/show_bug.cgi?id=38768
Comment 1 Rainer Bielefeld Retired 2011-07-22 09:27:56 UTC
NOT reproducible as a general problem with "LibreOffice 3.4.1 RC2 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:202)]". I assigned a self written macro with a button and that worked fine.

@Thomas Foerster:
Please contribute a sample document where simply a button has to be pushed for the test.
Do you also see that with old assignations or only when you try to assign newly?
Does the link to the dev-builds mean that you also observe the problem with Master?
Comment 2 Thomas Foerster 2011-07-22 10:01:03 UTC
This is not a problem with a macro which is assigned with a button. Please read my comment again: It is a problem with a macro which is assigned with Tools->Customize->Events(!!!).

"Please contribute a sample document where simply a button has to be pushed for
the test."
See above!

"Do you also see that with old assignations or only when you try to assign
newly?"
With both.

"Does the link to the dev-builds mean that you also observe the problem with
Master?"
Yes.
Comment 3 Rainer Bielefeld Retired 2011-07-22 10:46:52 UTC
[Reproducible] with "LibreOffice 3.4.1 RC2 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:202)]". I Assigned a macro to "Save Cocument"
- worked fine for a macro contained in WRITER document
- did not work for Macro from LibO Macros "Hello World"

Regression, I tested with 3.3.3 Portable successfully "Hello World" assigned to "Save Document".
Comment 4 Thomas Foerster 2011-07-22 10:58:32 UTC
Please try "Activate Document" and "Print Document" (see above)...
Comment 5 Thomas Foerster 2011-07-29 04:56:56 UTC
Change in 3.4.2 RC3: It is not fixed at all:

Macro now works again with "Activate Document" (Tools -> Customize -> Events) -
but could NOT be REMOVED! Even after saving and reloading the event is still
there.

Macro DOES NOT work with "Print Document"!
Comment 6 Rainer Bielefeld Retired 2011-07-29 07:30:58 UTC
I see that working with OOo 3.1.1, but not with OOo 3.3 or LibO 3.3.0 Portable, what does not match with my experience from Comment 3. Strange!

Also seems to be a problem with other LibO applications, not only writer.

@Thomas Foerster:
No doubt, the problem is CONFIRMED, we are only waiting for a developer having time, skills, interest.

If you can contribute information that that problem might affect many users and important function less, we can think about rising priority, but currently I se that with normal priority.
Comment 7 Rainer Bielefeld Retired 2011-09-19 09:11:06 UTC
*** Bug 39043 has been marked as a duplicate of this bug. ***
Comment 8 Björn Michaelsen 2011-12-23 13:23:12 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 9 Björn Michaelsen 2012-03-01 09:04:05 UTC
Regression does appear in oldest version of bibisect-3.5.tar.lzma and must be older.
Comment 10 Niklas Johansson 2012-06-11 07:27:38 UTC
Reproduced problem with document print event with LibreOffice 3.4.0 (Win XP) as well as LibreOffice 3.6.0 Beta 1 (Win 7 64 bit).
Comment 11 retired 2014-11-10 10:10:45 UTC
This is a very old bug. Is this persisting with the latest nightly builds?

http://dev-builds.libreoffice.org/daily/master/

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED (should it be persisting) or WORKFORME (should it be solved with a newer LO version).
Comment 12 Gordo 2015-05-25 12:30:55 UTC
Could not reproduce.

Windows Vista 64
Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16

4.1.6.2

Changed to RESOLVED WORKSFORME.