Bug 39514 - Mouse is frozen temporarily after cut, copying or pasting symbol shapes
Summary: Mouse is frozen temporarily after cut, copying or pasting symbol shapes
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.2 RC2
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-24 15:42 UTC by Glen Winters
Modified: 2011-07-26 00:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Glen Winters 2011-07-24 15:42:10 UTC
When editing a drawing, if click on a Symbol Shape such as a square and then try to copy it, there's a very short period where the mouse is frozen. After pasting, there's an even longer period (maybe 0.5s) where the mouse freezes and I can't go to click on the pasted shape and move it.

I've found it's not a consistent frozen period. Sometimes it's not noticeable. Also, it seems to be worse when copying multiple objects. This is mostly an annoyance, not an error.
Comment 1 Glen Winters 2011-07-24 15:45:10 UTC
I just noticed this delay also occurs when you hit undo or redo and it either has to delete or restore a shape.
Comment 2 Jeffrey 2011-07-24 21:09:01 UTC
Failed to reproduce on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.

What do you mean by "symbol shapes"? Is it the shapes inserted from the draw toolbar or symbols in special characters? I have tried both and they do not cause any delay problems.

This might seem like a trivial questions but adding some steps to reproduce would be great.
Comment 3 Glen Winters 2011-07-25 01:01:50 UTC
I'm talking about the Symbol Shapes from the Drawing toolbar. That's the name of them when I hover over the icon.

1) Draw a Symbol Shape from the Drawing toolbar.
2) Click on the shape.
3) Hit Ctrl+C to copy.
4) Hit Ctrl+V to paste and move the mouse while doing so or shortly after.

In step four, I notice a delay between pasting and getting response from the mouse. Also, moving the mouse during step 3 can cause some delay but I only noticed that after testing because I don't typically move the mouse while copying.
Comment 4 Glen Winters 2011-07-26 00:04:44 UTC
It seems that this is happening in some other programs, so it's not a LibreOffice bug.
Comment 5 Glen Winters 2011-07-26 00:05:51 UTC
This seems to be a problem I'm having across several programs. It's not just an issue with LibreOffice Calc.