Download it now!
Bug 39587 - [FILESAVE] Calc is destroying russian letters when saving to Excel 5.0 or Excel 95
Summary: [FILESAVE] Calc is destroying russian letters when saving to Excel 5.0 or Exc...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: x86 (IA32) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 43529 46865 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-27 01:52 UTC by Nikolay Morozov
Modified: 2013-11-24 22:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Resulting trash (15.00 KB, application/msword)
2011-07-27 01:52 UTC, Nikolay Morozov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolay Morozov 2011-07-27 01:52:00 UTC
Created attachment 49606 [details]
Resulting trash

I have an Excel file exported by 1C 7.7
LibO opened if perfectly, i make some modifications and save it keepeing format.
But when i try to reopen what sased all russian letters are converted into "?" characters.
If i use "Save As" the default selected format is "Excel 5.0". 
Saving manualy to ODS or Excel 2003 works fine.
Comment 1 Nikolay Morozov 2011-07-27 01:53:32 UTC
Tested on 3.4.1 and 3.3.2 versions
Comment 2 tester8 2011-07-31 10:46:21 UTC
Related to 33100, so I assigned it to Kohei Yoshida.
Comment 3 Kohei Yoshida 2011-08-01 07:55:53 UTC
I'm afraid that we don't have resources to care for this outdated file format.  Excel 97 and above supports unicode in the file format, but Excel 95 and earlier doesn't.  And we will soon disable saving to this format type anyway since nobody maintains this arcane format.

For now, I'll reset the ownership to default since I won't be working on this.
Comment 4 Nikolay Morozov 2011-08-07 23:19:43 UTC
(In reply to comment #3)
> I'm afraid that we don't have resources to care for this outdated file format. 
> Excel 97 and above supports unicode in the file format, but Excel 95 and
> earlier doesn't.  And we will soon disable saving to this format type anyway
> since nobody maintains this arcane format.
> 
> For now, I'll reset the ownership to default since I won't be working on this.

 Disabling saving to Excel 5.0 will be a good solution
Comment 5 Urmas 2011-09-05 10:42:47 UTC
I disagree. Excel 95 format is a popular format for data exchange between 3rd-party applications.
Comment 6 Björn Michaelsen 2011-12-23 12:21:24 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 Nikolay Morozov 2011-12-26 04:55:56 UTC
Reproduced with 3.5.0Beta2 Windows
Comment 8 Urmas 2012-01-11 11:01:50 UTC
*** Bug 43529 has been marked as a duplicate of this bug. ***
Comment 9 Urmas 2012-03-02 00:26:10 UTC
*** Bug 46865 has been marked as a duplicate of this bug. ***
Comment 10 Nikolay Morozov 2012-03-02 00:34:36 UTC
Also Afects Excel 95 Format
Comment 11 Vlad Gorishny 2012-05-04 06:00:46 UTC
In version 3.5 this bug is still present.
I noticed another feature. In your program, I installed the saving of tables in a format Microsoft Exel 97/2000/XP/2003. I opened the document, then make some changes and save it (Ctrl + S). The file was saved in the format in Excel 95!!! Although if you do "Save as ..." (Ctrl + Shift + S) I proposed to save in Microsoft Exel 97/2000/XP/2003 format and any errors are present.
Please make sure to match the format for saving the settings of the program.
Comment 12 sunweb 2012-05-08 06:51:29 UTC
I fail to see the reason of deleting suppport of 1252 encoding in xls'95. It worked well before now its pain in the a**. To save something now you have to click more("save as" or "save to ODS"), thats disturbing.

Could you atleast add an option of what encoding for what files to choose in save options ? So that we can save in XLS 97 without prompt questions ? Such option would save time again when you're going to remove full support for any other format.

Ofcourse the problem because of old as hell programs that uses this ancient format only but they won't add anything newer anyway.
Comment 13 Urmas 2013-02-06 17:28:38 UTC
Marking as WONTFIX due to export filter's demise.