Download it now!
Bug 39628 - Background image formatting in PDF Spreadsheet Export Covers Cells
Summary: Background image formatting in PDF Spreadsheet Export Covers Cells
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-28 08:53 UTC by Rob
Modified: 2015-01-28 12:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Graphic Background in Spreadsheet, Graphic not necessarily larger than page (46.00 KB, application/pdf)
2011-07-28 18:56 UTC, Jeffrey
Details
Graphic Background in Spreadsheet, Graphic definitely than page (118.37 KB, application/pdf)
2011-07-28 18:57 UTC, Jeffrey
Details
Mock-up of disappearing text in pdf export (409.95 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-07-29 04:04 UTC, Rob
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rob 2011-07-28 08:53:18 UTC
I created a spreadsheet and wanted a full page background image behind the cells.

Import > Fine
Set as background > Fine
Print > Fine
Save as ODS > Fine
Export as PDF > Failed

When the PDF is created only the background image shows, no cells. This is true for PNG and JPG.

I found the critical variable is whether the image is larger than the page size. The very edges of the image were bigger than what Calc felt a page should be. When I reduced the size of the image by a few pixels the content of the cells appeared in PDF exports.

Hope this helps.
Comment 1 Jeffrey 2011-07-28 18:56:56 UTC
Created attachment 49697 [details]
Graphic Background in Spreadsheet, Graphic not necessarily larger than page

Failed to reproduce on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.

Here is an attached document of a background image successfully displayed behind cells. This is for a png file.

I also set a page size of 2.3" by 2" with one cell. That one came out fine as well. (See second attachment). So in this case the image size was drastically larger than the page.

Thanks.
Comment 2 Jeffrey 2011-07-28 18:57:54 UTC
Created attachment 49698 [details]
Graphic Background in Spreadsheet, Graphic definitely than page

Also, it would be great if you could post an attachment of the faulty document if it is not confidential.
Comment 3 Rob 2011-07-29 04:04:19 UTC
Created attachment 49708 [details]
Mock-up of disappearing text in pdf export

Hi, I didn't have the time to put together an example at the time. Here is an example.

The original file is an invoice, so I've put together a mock-up with the same elements. The text in cells still disappears for me with this file when exported to pdf.

Hope this helps.

Rob
Comment 4 Björn Michaelsen 2011-12-23 12:27:58 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Florian Reisinger 2012-08-14 14:03:30 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:04:25 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:08:57 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 Florian Reisinger 2012-08-14 14:10:57 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 9 sasha.libreoffice 2012-09-29 07:22:02 UTC
reproduced in 3.6.1 on Fedora 64 bit (initial version was 3.3.3)
Comment 10 QA Administrators 2015-01-05 17:52:03 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
Comment 11 Buovjaga 2015-01-28 12:35:52 UTC
Text shows fine when exporting attachment 49708 [details] -> WFM.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36