Download it now!
Bug 39658 - xls file displayed differently then in Excel
Summary: xls file displayed differently then in Excel
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other All
: medium normal
Assignee: zinph
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-29 00:20 UTC by cristi falcas
Modified: 2016-04-08 15:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
example file (1.80 KB, application/zip)
2011-07-29 00:22 UTC, cristi falcas
Details
excel condition (123.69 KB, image/png)
2013-05-01 01:34 UTC, Thomas Arnhold
Details
calc condition (101.30 KB, image/png)
2013-05-01 01:34 UTC, Thomas Arnhold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cristi falcas 2011-07-29 00:20:41 UTC
The attached file is displayed "normally" in Excel, but in Calc all rows have a red background. 

Tested on Fedora and Windows.
Comment 1 cristi falcas 2011-07-29 00:22:04 UTC
Created attachment 49704 [details]
example file

The file was created in Calc with copy/paste from Excel
Comment 2 Jeffrey 2011-07-29 03:09:18 UTC
Reproduced on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.

Very strange. The cells have no color fill, yet appear red. I suppose this means that Excel displays the cells correctly.
Comment 3 cristi falcas 2011-07-29 03:14:53 UTC
(In reply to comment #2)
> Reproduced on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.
> 
> Very strange. The cells have no color fill, yet appear red. I suppose this
> means that Excel displays the cells correctly.

Yes: first row has an yellow background, the rest of have no background color.
Comment 4 Björn Michaelsen 2011-12-23 12:20:46 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 cristi falcas 2011-12-24 01:39:42 UTC
re tested with 3.5 beta2. The problem is still present
Comment 6 Thomas Arnhold 2013-05-01 01:34:29 UTC
Created attachment 78675 [details]
excel condition
Comment 7 Thomas Arnhold 2013-05-01 01:34:44 UTC
Created attachment 78676 [details]
calc condition
Comment 8 Thomas Arnhold 2013-05-01 01:35:52 UTC
This is because of the underlying condition in the excel document. But I don't understand the logic of this condition.

Markus I assign this to you, feel free to change.
Comment 9 Thomas Arnhold 2013-05-01 01:39:41 UTC
This is the condition:

"Format only cells with" - "Cell value" - "unequal"

=INDIRECT("Dummy_for_Comparison!"&ADRESS(ROW();COLUMN()))
Comment 10 retired 2014-12-11 11:45:19 UTC
Seems Markus is not working on this. Freeing the bug.
Comment 11 QA Administrators 2015-12-20 16:05:35 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 12 zinph 2016-02-12 15:00:00 UTC
I am starting on it.
Comment 13 zinph 2016-02-24 16:02:05 UTC
Hello,

I am working on this bug, and I need help locating the codes for this matter. Is anyone actively working on this now? Any help, suggestion is appreciated. Thank you.
Comment 14 zinph 2016-02-26 14:39:26 UTC
Hello,

Could you please clarify step by step about what and how you were copying the table? Were you pasting plain text, or formula, number or text? Which option did you choose for copying and pasting? 

Did you also try to modify something about background color in the excel sheet, or libre office calc? I would very much appreciate it if you can answer these questions. Thanks!
Comment 15 cristi falcas 2016-02-26 15:57:01 UTC
I just did Ctrl+C and Ctrl+V. Nothing special was selected or done. 

I don't have the original xls file, and I wasn't allowed to publish it anyway.
Comment 16 zinph 2016-02-29 21:18:43 UTC
This is a conditional formatting issue. If you want to change the LibreOffice Calc document to how it looks like in Microsoft Office Excel, please do the following steps.
In LibreOffice Calc, go to:

1. Format
2. Conditional Formatting
3. Condition
Then, a message box will pop up, asking you this question:
"Do you want to edit the existing conditional format?"
4. Click "Yes"
In "Apply Style" line, you will see "Excel_CondFormat_1_1_1".
5. Change it to "default".
6. Click "Ok"

For clarification, it is not exactly a bug in LibreOffice. In conditional formatting setting, it states that if cell is not equal to the formula "=INDIRECT("Dummy_for_Comparison!"&ADRESS(ROW();COLUMN()))", the background color is set to red. According to this condition, all cells with content that doesn't match the formula should be red. All the filled up cells in the document don't actually match with the formula, so those cells are red. So, LibreOffice Calc is doing the right thing. 

However, in Microsoft Office, it doesn't seem to recognize the formula (I am not sure what can actually match with this formula???), so the conditional formatting isn't applied. Therefore, default mode is on, disregarding the conditional formatting rule. Hope it helps.