Download it now!
Bug 39677 - Text corruption bug when using Impress text custom animations.
Summary: Text corruption bug when using Impress text custom animations.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-29 20:22 UTC by rfvuhbtg
Modified: 2016-04-17 09:43 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
demonstrates the animation bug (28.28 KB, application/vnd.oasis.opendocument.presentation)
2011-07-29 20:22 UTC, rfvuhbtg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rfvuhbtg 2011-07-29 20:22:44 UTC
Created attachment 49734 [details]
demonstrates the animation bug

When using custom animations, if the text box border of the text to be animated overlaps with another text box--or if the text to be animated shares a text box with other text--then after the animation completes, the other text will become slightly corrupted.  It will become darkened, as if bolded, and look rougher (less anti-aliased) in general.  

This makes it difficult to use text animations and impossible to animate bulleted/numbered lists while maintaining a professional-looking slide.

Attached is a one-slide presentation that should demonstrate the problem.

(This was on an Intel HD graphics card--first generation Core i3)
Comment 1 Jeffrey 2011-07-31 18:04:10 UTC
Confirmed for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux.

Cannot pinpoint the exact reason for corruption, as you stated in your slide, but when I moved the text boxes away from each other, the text no longer became corrupted, so that very well may be the reason for the problem. Thanks for the great attachment and steps.
Comment 2 Björn Michaelsen 2011-12-23 12:24:39 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 rfvuhbtg 2012-01-03 11:33:28 UTC
I can confirm that it still happens with LibreOffice 3.5 beta 2...

Although in that version, the animations for the example slide do not work correctly at all.  In addition to the bug listed here, the entire slide shows up at once.  The text boxes do play their animation when it is time for them, but they are displayed on the slide even before that.
Comment 4 sasha.libreoffice 2012-03-29 00:45:41 UTC
Reproduced in 3.3.4 and 3.5.1 on Fedora 64 bit
Changing to 3.3.4 as most early reproducible

If disable hardware acceleration, animation also disappears. Text just appears.
Comment 5 A (Andy) 2013-04-24 21:39:09 UTC
not reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

Does this issue still persist for you with the latest release of LO?
Comment 6 sasha.libreoffice 2013-04-25 10:33:06 UTC
text corruption in 4.0.2 not reproducible
If disable hardware acceleration, animation also disappears.
So, initial bug not reproduced. Absence of animation is another bug or may be even intended behaviour. IMHO bug may be closed
Comment 7 QA Administrators 2015-03-04 02:22:01 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 8 Jean-Baptiste Faure 2015-03-07 09:48:21 UTC
Seems to be still there and related to hardware acceleration.
LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64

Best regards. JBF
Comment 9 tommy27 2016-04-16 07:25:19 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 10 Jean-Baptiste Faure 2016-04-17 09:43:30 UTC
Not reproducible anymore with LO 5.1.3.0.0+ and current master (Version: 5.2.0.0.alpha0+ Build ID: 7fbeba2c4c1094204b5db7320dad8f667e291c01) both built at home under Ubuntu 15.10 x86-64.

Closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF