Bug 39751 - links to external data do not work if the data file is a symbolic link
Summary: links to external data do not work if the data file is a symbolic link
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-02 02:06 UTC by George
Modified: 2012-02-15 21:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description George 2011-08-02 02:06:43 UTC
On Ubuntu 10.04, with LO 3.3.2, I have two files that I use every month, where one file updates data from the other. The files are both buried deep in the directory tree, but I have several directories that link to various levels of the tree.
The link to external data does not work unless the full, actual pathname is used. Symbolic links in the path cause the data to display #REF? errors.
Workaround to fix this is to use the full pathname.
It would be nice to use shorter links.
Comment 1 Björn Michaelsen 2011-12-23 12:29:10 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Rainer Bielefeld Retired 2012-02-15 09:21:43 UTC
@George:
Still a problem for you? if yess, mMay be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem?
Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach a sample document (not only screenshot)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (due to example in Bug 43431)
– if possible contribute an instruction how to created a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC 
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO version and localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  -- everything else crossing your mind after you read linked texts
Comment 3 George 2012-02-15 17:48:16 UTC
@Rainer,
It still seems to be a problem, but I can't figure out consistently how to re-create it. It will be hard to determine if the bug (if it is a bug) is related to Lo or to something else.

I can't consistently reproduce it to make a useful bug report, but I do have problems every time I try to access the linked files.

Sorry not to be more helpful.
Comment 4 George 2012-02-15 19:37:34 UTC
Just an additional note:
I am playing with the files at the moment. Trying to replicate the error in a new sheet just doesn't seem to work. 
Linking there seems to work fine. Must be something with how I wrote my spreadsheet.
Comment 5 Rainer Bielefeld Retired 2012-02-15 21:37:57 UTC
@George:
Definitively not FIXED.
Please feel free to reopen the bug when you can contribute information that will allow to reproduce the bug.