Download it now!
Bug 39803 - Make Libreoffice accessible by default
Summary: Make Libreoffice accessible by default
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: x86 (IA32) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on: 39833 39956
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-03 07:23 UTC by Jean-Philippe MENGUAL
Modified: 2014-02-06 17:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots, see Comment 3 (101.39 KB, image/png)
2011-08-03 22:03 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Philippe MENGUAL 2011-08-03 07:23:46 UTC
Hi,

Waiting for news about Iaccessible2, Symphony, OOo, Apache, etc... well waiting for news about this mess, I hope I'll make things progress
through various little points. Here's what reported an user of Windows
Vista, with the screen reader NVDA.

At the 1st starting of LibreOffice, NVDA doesn't work. In options menu,
accessibility tab, NVDA says the tabs but then, doesn't read anymore the
dialogue. The user checks then the checkbox "support software for
disabled people". He asks now: couldn't this checkbox checked by
default? If not, it'd be important to give a way to a blind people to do
the above process with some audio help, as NVDA doesn't speak until this
checkbox is checked.

Thanks for your answer. Although it won't give a whole accessibility with Windows, it'll make easier use LibreOffice for impaired people with NVDA with a speech synthetiser. For a better accessibility in general, I guess we've to wait and see evolution of some issues.

Regards,
Comment 1 Rainer Bielefeld Retired 2011-08-03 08:37:27 UTC
I don't think that it would be a good idea to to have that option checked by default. May be resources will required what are not available on every Computer?
But a prominent selector in a setup dialog might be a compromise?
Comment 2 Jean-Philippe MENGUAL 2011-08-03 10:53:37 UTC
Hi,

In my opinion, but of course I "defend" my idea, it's easier and more accessible if the option is enabled by default, and the user has to disable if useless. Because every user can disable, whereas not every user can enable. So enabling the option by default would match better to the accessibility idea.

What do zou mean with "Prominent selector"? Your idea gives me another: if this option isn't enabled by default, we could create a shortcut in Libreoffice to enable/disable this feasnve, in other words, to check/uncheck the checkbox. If the shortcut is properly documented in the documentation, wiki, etc., it may be a good alternative. Does this idea appear a good compromise too?

Waiting for your opinion,
Comment 3 Rainer Bielefeld Retired 2011-08-03 22:03:00 UTC
Created attachment 49898 [details]
Screenshots, see Comment 3

Java Access Bridge is required, so we can not install "Accessible by default".

Prominent means: In one of the setup dialogs, I believe in the same one where you have to select whether you want to proceed default or custom installation
Comment 4 Jean-Philippe MENGUAL 2011-08-04 07:59:48 UTC
Ok I understand. Enabling the user to choose at install time seems to be a good compromise indeed. What about creating a shortcut to toggle use/not use accessibility tools? With the documented condition that Java bridge to be installed.

Anyway I'm ready to test what will exist about this issue. Ready to test the solution.

Regards,
Comment 5 Rainer Bielefeld Retired 2011-08-04 23:03:42 UTC
@Jean-Philippe MENGUAL:
I found several additional contradictions, inconsistencies and bugs during my research, some additional investigation will be required, I will continue and finish that next week.
Comment 6 Christophe Strobbe 2011-08-09 02:09:58 UTC
If LibreOffice can detect the presence of the Java Access Bridge when the user checks the box "Support assistive technology tools", could this detection also be performed during the installation?

Of course, if LibreOffice implemented IAccessible2, this detection would become unnecessary and support AT by default would be a bit easier, so I added a dependency on Bug 39956. (I realize that implementing IAccessible2 is also a lot more work.)
Comment 7 Björn Michaelsen 2011-12-23 12:23:46 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 8 sasha.libreoffice 2012-03-06 05:26:02 UTC
@ Jean-Philippe MENGUAL
Thanks for bugreport
As I understand, asked option enabled by default so that blind people can install and use office. IMHO it is optimal in future to create separate install file for blind people, where all needed options, extensions enabled and needed additional software installs.
May be exist some association of blind people that can help in this job?
Comment 9 Florian Reisinger 2012-08-14 13:59:40 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 10 Florian Reisinger 2012-08-14 14:00:50 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 11 Florian Reisinger 2012-08-14 14:05:33 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 12 Florian Reisinger 2012-08-14 14:07:35 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 13 V Stuart Foote 2014-02-06 17:22:54 UTC
For 4.3.0.0alpha+ builds of master onward, Java Access Bridge support has been removed. When a Windows AT is detected in use the IAccessible2 native Windows bridge activates.  

Effectively, the same behavior for UAA native bridges all supported OS, and Assistive Technology tool support activation is automatic.