Bug 39844 - EDITING: Crash while Undo action
Summary: EDITING: Crash while Undo action
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) Mac OS X (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-04 17:15 UTC by Frantisek Erben
Modified: 2013-11-24 22:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash while Undo action on Mac OS X 10.7 (74.25 KB, text/plain)
2011-08-04 17:16 UTC, Frantisek Erben
Details
test file (441.68 KB, application/vnd.oasis.opendocument.text)
2011-08-05 15:22 UTC, Frantisek Erben
Details
resume test file (32.50 KB, application/msword)
2011-11-03 12:49 UTC, Adrian Nye
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frantisek Erben 2011-08-04 17:15:32 UTC
Crash while multiple Undo action – approx. 5 times press Cmd+Z (Undo change image-fomula position in text). Crashlog included. Reproduced on Mac OS X 10.7.
Comment 1 Frantisek Erben 2011-08-04 17:16:52 UTC
Created attachment 49935 [details]
Crash while Undo action on Mac OS X 10.7
Comment 2 Jeffrey 2011-08-04 20:57:10 UTC
Sorry but could you be clearer with the steps to reproduce the problem and if the problem can not be easily pinpointed, could you perhaps describe the situation surrounding the crash in more detail? That would be great. I feel that right now there is not enough information to reproduce the problem.
Comment 3 Frantisek Erben 2011-08-05 15:22:48 UTC
Created attachment 49977 [details]
test file
Comment 4 Frantisek Erben 2011-08-05 15:31:40 UTC
I upload test file on this file I reproduce crash yesterday more then 3 times.
Unfortunatelly today (after reboot computer) I can't reproduce it.

There are several formulas at page 3. I manipulated with it (edit content and move it many times - at least 10 times), Writer crash when I fast and several times press Cmd+Z (undo action).

If you wouldn't be able reproduce it, sorry for useless bug :(
Comment 5 Milos Sramek 2011-08-09 10:48:01 UTC
I observe similar behavior in Writer.
Version: LibreOffice 3.4.2  OOO340m1 (Build:203)
Platform: Linux (Ubuntu 10.10)

How to reproduce:
1. open Writer
2. make sure the Edit/Changes/Record and Edit/Changes/Show are off
3. type in some text
4. switch Edit/Changes/Record on
5. delete something (delete, not add)
6. Hit CTRL/Z. The previous change is not undone. The cursor jumps to a random position, if CTRL/Z is hit again, random changes are done. Not always, but after a couple of CTRL/Zs LO crashes.

ferben, try to do the same with your document - I observed the same also with it after switching Edit/Changes/Record on. Is it the same, as you observed before?

Is OK with Lo 3.3.3

Milos
Comment 6 Frantisek Erben 2011-08-11 00:31:12 UTC
I tried Milos's reproduce sequence several times.
I confirm the same behavior: Jump to random position in document and random apply changes to text, but not crash. Crash might depend on number of changes, or time of launch.
Comment 7 digital ant 2011-08-20 19:32:14 UTC
LibO 3.4.3 rc1 on OSX 10.6.8 - cannot reproduce Ferben's example with test doc, but can confirm Milos sequence does produce crash.
Comment 8 Adrian Nye 2011-11-03 12:49:26 UTC
Created attachment 53123 [details]
resume test file
Comment 9 Adrian Nye 2011-11-03 12:52:15 UTC
Comment on attachment 53123 [details]
resume test file

I edited a with OSX 10.7.2 and LibreOffice 3.4.3.   When I hit command-Z, it
beachballs then crashes the machine requiring hard reset if you don't force
quit soon after it happens.  The CPU is at 100% according to activity monitor.
I will attach the file I used (a resume).

I rebooted and tried again and same thing occurs, so it's repeatable.
Comment 10 Björn Michaelsen 2011-12-23 12:21:09 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 11 Frantisek Erben 2011-12-27 14:05:28 UTC
Unable to reproduce in LOdev 3.5.0beta2 
Build ID: da8462e-760cc4d-f39cf3d-1b2857e-60db978

Fixed by development.