Bug 39878 - FILEOPEN - Paste of codepage 437 files no longer working
Summary: FILEOPEN - Paste of codepage 437 files no longer working
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-06 02:16 UTC by robert
Modified: 2014-12-03 09:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
CSV file with codepage 437 data (4.07 KB, text/csv)
2011-08-06 02:16 UTC, robert
Details
Screenshot of input data in RE (185.34 KB, image/png)
2014-12-02 17:23 UTC, Robert
Details
Result after data pasted as per filename (100.82 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-02 17:25 UTC, Robert
Details
Result after data pasted as per filename (100.97 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-02 17:25 UTC, Robert
Details
Screenshot of import as per filename (202.33 KB, image/png)
2014-12-02 17:27 UTC, Robert
Details
Screenshot of import as per filename (230.01 KB, image/png)
2014-12-02 17:28 UTC, Robert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robert 2011-08-06 02:16:37 UTC
Created attachment 49986 [details]
CSV file with codepage 437 data

If the attached codepage 437 file is edited with a CP437 aware editor, i.e. the a- and u-umlaut characters are visible as such, and the CUT data is subsequently Paste'd into Calc, the dialog will allow you to specify CP 437, but the characters are not correctly pasted.

FWIW, opening the file as .CSV and specifying CP 437 DOES work OK.
Comment 1 Björn Michaelsen 2011-12-23 12:20:38 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Robert 2014-11-25 22:12:34 UTC
This bug is still present in the current version:

Version: 4.3.4.1
Build ID: bc356b2f991740509f321d70e4512a6a54c5f243

Open the attached in a codepage 437 aware editor so that ü & ä's actually show as ü and ä's, cut the data, and paste into an empty cell. The pop-up dialog will allow specification of codepage, and select "Western Europe (DOS/OS2-437/US) then paste.

ü and ä characters will not be converted!!!

ü are completely discarded, ä display as some kind of quote
Comment 3 Urmas 2014-11-27 11:53:37 UTC
I do not understand. You copy data from your editor, you paste them as Unicode (UTF-16 on Windows). How does CP437 come into the picture?
Comment 4 Robert 2014-12-01 18:41:26 UTC
The data comes from an editor that knows NOTHING, ZILCH from Unicode. I cut CP437 data, paste it into Calc, telling Calc that the data is CP437 and it refuses to translate the earlier mentioned characters.
Comment 5 Urmas 2014-12-02 13:53:02 UTC
What editor do you use? Every text in Clipboard is stored in Unicode, so it should be pasted as Unicode.
Comment 6 Robert 2014-12-02 14:22:01 UTC
The editor is RE and it's a rewrite of an old DOS editor. I don't have access to the source and the original author has long disappeared. 

Pasting it as "Unicode (UTF-16)" gives exactly the same result as pasting it as "Western Europe (DOS/OS2-437/US)", i.e. with mangled characters.

The only thing I do know is the fact that older versions of LO Calc would paste the data correctly, i.e. they would honour CP437 and ü and ä would appear in the sheet.
Comment 7 Urmas 2014-12-02 16:54:08 UTC
Please make a screenshot of your editor with the text in it, and the text import dialog.
Comment 8 Robert 2014-12-02 17:23:49 UTC
Created attachment 110365 [details]
Screenshot of input data in RE
Comment 9 Robert 2014-12-02 17:25:00 UTC
Created attachment 110366 [details]
Result after data pasted as per filename
Comment 10 Robert 2014-12-02 17:25:34 UTC
Created attachment 110367 [details]
Result after data pasted as per filename
Comment 11 Robert 2014-12-02 17:27:36 UTC
Created attachment 110368 [details]
Screenshot of import as per filename
Comment 12 Robert 2014-12-02 17:28:02 UTC
Created attachment 110369 [details]
Screenshot of import as per filename
Comment 13 Robert 2014-12-02 17:29:54 UTC
OK, added five files, 

- screenshot of data to be pasted in RE

- screenshot of data to be imported as UTF-16
- resulting .ODS file from above

- screenshot of data to be imported as Western Europe (DOS/OS2-437/US)
- resulting .ODS file from above
Comment 14 Urmas 2014-12-02 19:40:40 UTC
Could you please give a link to the web page of your RE editor?
If you open your datafile in Wordpad (as DOS text) and paste it in Calc, do you have this problem?
Comment 15 Robert 2014-12-02 20:06:22 UTC
You would have to contact its author, Cary Ravitz @ http://ravitz.us/  

A DOS version is available on http://ravitz.us/rs/ as http://ravitz.us/rs/raved.zip 

I've been using a very old beta (0.94) of the Windows version since 2008, and as it satisfies all my needs, I've never asked him if he ever updated it.
Comment 16 Urmas 2014-12-03 04:03:03 UTC
Your clipboard does not contain the letters you think your editor put there.
Either use the editor which can do that, or open the file instead of using the clipboard.
Comment 17 Robert 2014-12-03 09:50:22 UTC
Easy to blame someone else!

Maybe you'd like to explain why this was working OK in earlier versions (around the time I entered the bug) of LO?