Bug 40027 - Data point symbols are wrong in import Excel xls-files
Summary: Data point symbols are wrong in import Excel xls-files
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2011-08-11 14:09 UTC by Regina Henschel
Modified: 2019-11-07 11:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File with test chart (48.50 KB, application/ms-excel)
2011-08-11 14:09 UTC, Regina Henschel
Details
png-Screenshot added (67.50 KB, application/ms-excel)
2017-01-03 22:40 UTC, Regina Henschel
Details
File converted to current Excel 365 format (28.39 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-11-06 15:33 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2011-08-11 14:09:47 UTC
Created attachment 50143 [details]
File with test chart

Open Attached xls-document, which has been produced with Excel 2010. It contains a chart with different symbols for the data points. Below the chart is a picture that shows, how the chart looks in Excel.

Open the document in LO3.3. The different symbols are assigned to different symbols in LO, as far as it is possible. Some symbols are not available in LO and therefore get an ersatz.

Now open the document in LO3.4. All symbols are imported as "diamond".

This is a regression.
Comment 1 sasha.libreoffice 2012-04-26 01:59:45 UTC
Reproduced in 3.3.4 (many shapes are lost) and in 3.5.2 (2 shapes: small rectangle and circle) are lost. In both versions lost color. Used Fedora 64 bit

in msExcel 2003 all shapes colored, colors very resembles screenshot, but differs. Shapes are the same as on screenshot, but some of them are in blue squares. 

Changing version to 3.3.4 as most early reproducible
Comment 2 A (Andy) 2014-10-11 16:00:57 UTC
Reproducible with LO 4.3.2.2 (Win 8.1)
Comment 3 QA Administrators 2015-10-14 19:56:36 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-12-02 11:31:49 UTC
Still confirmed.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a7c3a2a9be83686657c06f37d521f9f6d2004ddd
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-28_04:39:18
Locale: fi-FI (fi_FI)
Comment 5 QA Administrators 2017-01-03 19:40:12 UTC Comment hidden (obsolete)
Comment 6 Regina Henschel 2017-01-03 22:40:36 UTC
Created attachment 130128 [details]
png-Screenshot added

The kind of symbols are better now. But the colors of the markers are wrong.

I have tested Version: 5.4.0.0.alpha0+
Build ID: 1cb1cc30b5eb75483b6aaeec0192f7ee1d833461
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-01_23:25:36
Locale: de-DE (de_DE); Calc: group
Comment 7 Regina Henschel 2018-11-06 15:33:05 UTC
Created attachment 146364 [details]
File converted to current Excel 365 format

The color of the markers is missing. All markers are red. Tested in Version: 6.2.0.0.alpha1+ (x64)
Build ID: f825e6d4082c0d0beb1c95b881f6a2ee9bfc9161
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-05_00:20:26
Locale: de-DE (en_US); Calc: CL
Comment 8 QA Administrators 2019-11-07 03:33:59 UTC Comment hidden (obsolete)
Comment 9 Regina Henschel 2019-11-07 11:52:01 UTC
The colors of the data point symbols are still missing.
Tested with Version: 6.4.0.0.alpha1+ (x64)
Build ID: 7c6226bee72805db7f0e567ca9f06c786a7d0da2
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded