Bug 40073 - LO fails to import standard frame styles properly when UI is not english
Summary: LO fails to import standard frame styles properly when UI is not english
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) All
: medium major
Assignee: Elie Roux
URL:
Whiteboard: odf target:4.4.0 target:4.3.0.1 targe...
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-14 03:54 UTC by Elie Roux
Modified: 2014-06-10 09:42 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
test file (34.37 KB, application/vnd.oasis.opendocument.text)
2011-08-14 03:54 UTC, Elie Roux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elie Roux 2011-08-14 03:54:38 UTC
Created attachment 50195 [details]
test file

Hello,

I have a very strange bug with the french translation of LibreOffice : 
 - 3.3 on Linux
 - 3.4 on Linux
 - 3.4 on Windows

If I don't install the french translation of LibreOffice under Linux, the attached document works properly.

Now if I install the french translation, I have a strange bug which you can reproduce as follow :
 - click on the frame in the middle of the third page
 - F11
 - double click on the frame style "Note de marge"
 - the Frame moves
 - save the file
 - close LibreOffice
 - reopen the file in LibreOffice
 - the Frame is still in the middle, as if it never moved...

This bug doesn't appear if I use the english translation and the style "Marginalia".

Thank you,
Comment 1 Björn Michaelsen 2011-12-23 12:41:03 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Elie Roux 2012-01-06 02:11:53 UTC
Hello,

I've just tested with LO3.5 beta2, and the bug is still here. Please take it seriously, I think it's easy to fix (it's a problem of translation of styles), and very annoying: it prevents me from telling everyone to use LO, as they need a french version, but it's buggy with the files I use...

Anyway, I'm really excited to see that most of the annoying ""features"" of OO.o are gone and are replaced by great new ones!

Thank you,
-- 
Elie
Comment 3 A (Andy) 2013-05-04 19:27:41 UTC
@Élie: Because this report is unfortunately already quite old, I would like to ask, whether this issue did still persist for you with the latest release of LO?

@Sophie: Or can you maybe also confirm this issue?
Comment 4 sophie 2013-05-05 07:15:14 UTC
Hi, So tested with Version 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39) and the bug is still here. Of course it's not a l10n issue. I'll investigate further and come back to give more context. Regards - Sophie
Comment 5 sophie 2013-05-05 12:41:17 UTC
So, we have reproduced it also under Windows 7/64 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39).
To simply reproduce it,
- install the FR pack and set LO to French UI
- File > New > Text
- Format > Page > Left margin set to 5 cm
- Modify Frame style 'Marginalia', under the Type area, Horizontal position : From left 1.5 cm for the Left page margin
- Insert > Frame > OK
- Apply the Frame Style "Marginalia"
- The frame is set to the margin
- Save, close, reopen
- The frame is at the center of the page
then
- Just set the UI to English
- close, reopen
- the frame is set to the margin
So the bug is confirmed. Sophie
Comment 6 Elie Roux 2014-06-03 19:34:07 UTC
Still confirmed in current master
Comment 7 Elie Roux 2014-06-06 16:20:51 UTC
Sorry to spam a little, but it's quite an important bug and I think it will help non-english users in their migration...

Note that the bug only affects ODF format (.doc format imports well in both english and non-english UI).
Comment 8 Elie Roux 2014-06-08 20:33:25 UTC
For information, the bug is also present in AOOo (https://issues.apache.org/ooo/show_bug.cgi?id=125072).
Comment 9 Adolfo Jayme 2014-06-09 07:05:32 UTC
Hey Elie, thank you very much from a translator. Your work on this will fix the root cause of bug 63141, for example. :-)
Comment 10 Elie Roux 2014-06-09 07:36:32 UTC
Adolfo,

the fix I uploaded (https://gerrit.libreoffice.org/#/c/9683/) is only for frame styles... I'll test today to see if there are other elements impacted by the bug, fixing them shouldn't be so hard now that I know how...

Please tell me if there are other elements impacted!

Thanks,
Comment 11 Commit Notification 2014-06-09 09:30:08 UTC
Elie Roux committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6f6673c5d1b4e6ea4982621f2817eb5d5dc10377

fix fdo#40073 : look for translated frame styles



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2014-06-09 10:24:01 UTC
Elie Roux committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22c4461490fdafdb09ae61e0fa1d97e3b0e35c6f&h=libreoffice-4-3

fix fdo#40073 : look for translated frame styles


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2014-06-09 10:35:04 UTC
Elie Roux committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dc59f010248fbb95d7a67ccb914e86c457dcea3a&h=libreoffice-4-2

fix fdo#40073 : look for translated frame styles


It will be available in LibreOffice 4.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2014-06-10 08:21:11 UTC
Elie Roux committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f62c625c96bcff3694ceeeab989a4080f6d0982c&h=libreoffice-4-2-5

fix fdo#40073 : look for translated frame styles


It will be available already in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.