Bug 40429 - Navigation button icon does not scale and gets cut off
Summary: Navigation button icon does not scale and gets cut off
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-27 22:16 UTC by Timothy Arceri
Modified: 2014-08-02 10:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Cut off icon (12.47 KB, image/jpeg)
2011-08-27 22:16 UTC, Timothy Arceri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Arceri 2011-08-27 22:16:51 UTC
Created attachment 50626 [details]
Cut off icon

In Ubuntu, the navigation button icon does not scale. The button is on the bottom-right corner of the window, in the middle of the two "double arrows". Should be a little circle, but it doesn't fit.

See the attached image.

This was confirmed on my eeePc not sure if that causes scroll bars to be thinner than normal.
Comment 1 Rainer Bielefeld Retired 2011-08-28 21:47:54 UTC
NOT reproducible with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]". 

Related to Dinux, Distro, Theme?

@Timothy Arceri:
What Theme from menu 'Tools -> Options -> LibO -> View - UI - Icon style' do you use?
Comment 2 Timothy Arceri 2011-08-28 23:24:55 UTC
No this does not affect windows, the issue is Ubuntu (Unity Desktop) has very thin scroll bars.

The Icon Size ans Style are set to. Automatic and Automatic (Human)
Comment 3 Rainer Bielefeld Retired 2011-09-03 22:38:19 UTC
@Timothy Arceri
Did you select the originel Version accidently? Please keep in mind
<http://wiki.documentfoundation.org/BugReport_Details#Version>
Comment 4 A (Andy) 2013-04-27 11:59:57 UTC
not reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

Does this issue still persist for you in Linux with the latest release of LO?
Comment 5 Timothy Arceri 2013-04-27 23:27:39 UTC
Yes its still an issue in LO 4
Comment 6 Cor Nouws 2013-11-17 17:42:06 UTC
version field reflect the FIRST version with the issue ...
Comment 7 Samuel Mehrbrodt (CIB) 2013-11-21 12:29:45 UTC
The width of the scrollbar is dependent on the OS and theme used. So we decided to remove the navigator buttons from there for LibreOffice 4.3: http://cgit.freedesktop.org/libreoffice/core/commit/?id=3e8fe4d8e19be2ccd8f5bb898530e2f615a90321
Comment 8 bv1578 2014-08-02 10:13:30 UTC
(In reply to comment #7)
> The width of the scrollbar is dependent on the OS and theme used. So we
> decided to remove the navigator buttons from there for LibreOffice 4.3:

This is a decision too drastic, it has to be revised. Removing, or moving in hidden places, useful features is always a bad idea.
Now I can't navigate my document page by page, easily with the mouse, unless I keep permanently open the find-bar, which has nothing to do with usual document navigation and takes useless room since many users use it very rarely.

The issue reported in the screenshot is by far minor and could be solved by using smaller icon(s) (at the end it's a simple circle), or, at a certain point, by ignoring themes that have severe restrictions because if someone create a theme that doesn't allow to put a 7x7 pixels size icon inside a scroolbar, well, this is not LibreOffice's fault.