Bug 40454 - Manual installation on Linux is still way too cumbersome
Summary: Manual installation on Linux is still way too cumbersome
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-29 03:06 UTC by Daniel Kulesz
Modified: 2011-08-29 10:51 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Kulesz 2011-08-29 03:06:53 UTC
Installing LO on a major Linux Desktop (i.e. Ubuntu, Debian, RHEL) is very annoying: People need to download a .tar.gz archive (although the download page says "deb" or "rpm") then unpack it and then execute dpkg or rpm on their own on a bunch of packages.

Even worse: The uninstallation is even more complicated and basically works using a "hunt and pick" method with some "and if you leave this it probably won't be that harmful" hints. (see http://www.libreoffice.org/get-help/installation/linux/ ) Sorry guys, but you can't expect end users to scroll down through package lists in Synaptic and decide for themselves which packages to remove, especially if there is already an older LO version which came along with the linux distribution already!

My suggestions for improving the situation:
1.) Create ONE meta-package which depends on all the specific .deb or .rpm packages. The user should only have to install or uninstall this one, single package.
2.) Why not even merge all the particular single .deb and .rpm packages into one big giant package? dpkg -i giantlopackage.deb and apt-get autoremove --purge giantpackage.deb (on Debian) should do the trick then much easier!
3.) Provide a "real" tar.gz installation method, so that the user can just unpack a binary build of LO into i.e. the home directory and run it from there. (without desktop integration then of course)

The current situation with the huge installation / uninstallation hassle just prevents me (and I guess this affects a lot of other people as well) from installing LO alongside to the existing OOo installation of my current Linux distribution.

Cheers, Daniel
Comment 1 Don't use this account, use tml@iki.fi 2011-08-29 03:26:20 UTC
No. "People" don't need to do that. People need to use what their distro provides. It is up to distro packagers to make it easy for "people"
Comment 2 Daniel Kulesz 2011-08-29 10:51:18 UTC
Of course "people" are supposed to use the LO / OOo version their distribution already provides. But what if someone wants to upgrade the installed version manually?

If the "download" section is not targeted at casual users, you should probably mention this on the website. Still I think that it's not okay if only advanced system administrators and developers are supposed to download LO.

Why are "advanced" users expected to undertake all this hassle. Other software (i.e. Skype) is much easier to install and uninstall manually because it provides a single deb/rpm/tar.gz package for this purpose.