Download it now!
Bug 40461 - Tooltips get written Black on Black with KDE default theme bound to LibreOffice
Summary: Tooltips get written Black on Black with KDE default theme bound to LibreOffice
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All Linux (All)
: medium minor
Assignee: Luboš Luňák
URL:
Whiteboard:
Keywords:
: 39781 39784 40827 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-29 09:50 UTC by Xavier Poirot
Modified: 2012-03-19 11:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
You can see the bug here. (10.21 KB, image/png)
2011-08-29 09:50 UTC, Xavier Poirot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier Poirot 2011-08-29 09:50:24 UTC
Created attachment 50664 [details]
You can see the bug here.

I have installed KDE 4.7 recently, and bound the KDE theme to LibreOffice thanks to a package my distribution (ArchLinux) provides.

Without this package, I see the UI as in Java I suppose... Whatever,

With the KDE style, the UI is perfect, but the tooltips are written in black on a black background.

The only solution I've found at the moment is to change theme...

I am using the Oxygen colorset (default) in KDE (this is the colorset which puts the tooltips in blackOnBlack).

Deactivate/Reactivate tooltips in LibreOffice options does not fix the issue.
Comment 1 bugs.freedesktop.org 2011-08-31 14:50:50 UTC
I get the same thing on an earlier LO version.

LibreOffice 3.3.3 
OOO330m19 (Build:301)
tag libreoffice-3.3.3.1, Ubuntu package 1:3.3.3-1ubuntu2

running on

Linux 2.6.38-10-generic running KDE Development Platform 4.7.00 (4.7.0)
Comment 2 vitriol 2011-09-13 05:30:19 UTC
*** Bug 40827 has been marked as a duplicate of this bug. ***
Comment 3 Bruce Korb 2011-09-29 14:42:01 UTC
I am not going to mess with your bug database, but I surely think this is a duplicate of bug 39784.
Comment 4 Luboš Luňák 2011-10-10 03:24:53 UTC
*** Bug 39784 has been marked as a duplicate of this bug. ***
Comment 5 Luboš Luňák 2011-10-10 03:27:58 UTC
*** Bug 39781 has been marked as a duplicate of this bug. ***
Comment 6 rsimmons0 2011-10-19 22:22:52 UTC
This is listed as fixed.  Can someone tell me which version it is fixed in?
Comment 7 Luboš Luňák 2011-10-20 09:27:52 UTC
The next one.
Comment 8 rsimmons0 2012-01-28 11:28:07 UTC
I am now using 3.4.4 and this is not fixed.  My Kubuntu version is now 11.10 and using KDE 4.8.0.
Comment 9 Kenneth R 2012-02-19 12:15:18 UTC
Still here.

LO 3.4.4
KDE 4.7.4
Kubuntu 11.10

It also affects the formula tooltip, the one with the syntax.
Comment 10 Harun 2012-03-18 22:44:19 UTC
I saw this happening in version: LibreOffice 3.4.4 OOO340m1 (Build:402) (current in Ubuntu Oneiric).
I found that the tooltip background and foreground colours obey the KDE text colour settings Tooltip Background and View Text, respectively.
(These are the names as listed under System Settings -> Application Appearance -> Colours -> Colours tab -> Colour set: Common Colours. They seem to have different names depending on where you go to edit them.)

I have since upgraded to the current Oneiric version in ppa:libreoffice/ppa (LibreOffice 3.5.0 Build ID: 350m1(Build:13)).
With this build, the colours are taken from Tooltip Text and Tooltip Background colour settings as expected.

So, someone has fixed this bug, and the Tooltip Background/View Text settings provide a workaround for older versions.
Of course, a backport would be nice, if any package maintainers are watching... ;)
Comment 11 Luboš Luňák 2012-03-19 11:59:26 UTC
As confirmed by previous comment, this has been fixed at least since 3.5.0.