Bug Hunting Session
Bug 40505 - UI: HYPHENATION Right/Left arrow key reversed (keyboard)
Summary: UI: HYPHENATION Right/Left arrow key reversed (keyboard)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: medium minor
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-30 23:03 UTC by Niklas Johansson
Modified: 2011-12-23 13:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Simple patch (1002 bytes, patch)
2011-11-07 08:38 UTC, Niklas Johansson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Niklas Johansson 2011-08-30 23:03:47 UTC
In the hyphenation dialog the right arrow button selects the next hyphenation point while the right arrow key selects the previous hyphenation point. The left button/key has the same problem.


In the sourcefile cui/source/dialogs/hyphen.cxx 
These lines at the bottom looks a bit suspicious:

void SvxHyphenWordDialog::SelLeft()
{
    m_pImpl->SelRight_Impl();
}


void SvxHyphenWordDialog::SelRight()
{
    m_pImpl->SelLeft_Impl();
}

'*************************************************************

After changing these lines into:

void SvxHyphenWordDialog::SelLeft()
{
    m_pImpl->SelLeft_Impl();
}


void SvxHyphenWordDialog::SelRight()
{
    m_pImpl->SelRight_Impl();
}


Both the buttons and the arrows seams to behave as expected when I built and tested it.
Comment 1 Rainer Bielefeld Retired 2011-08-31 01:29:48 UTC
[Reproducible] with Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: f952331-4eb4f62-09af278)]". Arrow icons work as expected, but arrow keys on key board work swapped.

@Niklas Johansson
Your OS and LibO Version / Localization are?

@Cédric:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 2 Rainer Bielefeld Retired 2011-08-31 01:32:58 UTC
Seems to be a very ole problem, also see that with "LibreOffice Portable 3.3.3  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:301  Tag 3.3.3.1)]"
Comment 3 Niklas Johansson 2011-08-31 01:45:34 UTC
I did the testbuild on Ubuntu. I've seen the problem on Win 7 and XP, Mac OS X.

I've seen the problem in all versions of LibreOffice that I've used, from 3.3.1 to 3.4.2.

My guess is that it was introduced when OpenOffice.org reworked the hyphenation dialog to be more accessible, and that LibreOffice has inherited the bug. It wasn't there in OOo3.2 but in OOo3.3.
Comment 4 Rainer Bielefeld Retired 2011-08-31 02:27:39 UTC
Thank you for quick feedback!.
<http://wiki.documentfoundation.org/BugReport_Details#Version>
Comment 5 Niklas Johansson 2011-11-07 08:38:34 UTC
Created attachment 53250 [details]
Simple patch

A simple patch that fixes the problem with the reversed keys and makes sure that 

void SvxHyphenWordDialog::SelLeft()
goes to the left and that

void SvxHyphenWordDialog::SelRight()
goes to the right

and you may use it under the MPL/LGPLv3+ licenses.
Comment 7 Björn Michaelsen 2011-12-23 13:23:47 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.