Bug Hunting Session
Bug 40779 - FORMATTING Fontwork 'Coloured in' in Impress Slide Show, not in Normal mode
Summary: FORMATTING Fontwork 'Coloured in' in Impress Slide Show, not in Normal mode
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-11 04:43 UTC by Joshua O'Leary
Modified: 2015-03-08 19:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File showing the bug in impress. (36.92 KB, application/vnd.oasis.opendocument.presentation)
2011-09-11 04:45 UTC, Joshua O'Leary
Details
Normal View (127.12 KB, image/png)
2012-01-04 09:21 UTC, Joshua O'Leary
Details
Slideshow View (36.83 KB, image/png)
2012-01-04 09:21 UTC, Joshua O'Leary
Details
Normal View (LoDev Beta2) (128.93 KB, image/png)
2012-01-04 09:40 UTC, Joshua O'Leary
Details
Slideshow View (LoDev Beta 2) (29.88 KB, image/png)
2012-01-04 09:40 UTC, Joshua O'Leary
Details
View of help>about showing version info (132.78 KB, image/png)
2012-01-04 09:41 UTC, Joshua O'Leary
Details
Normal View (LoDev Beta2) - Test case attachment (180.56 KB, image/png)
2012-01-04 09:43 UTC, Joshua O'Leary
Details
Slideshow View (LoDev Beta2) - Test case attachment (239.04 KB, image/png)
2012-01-04 09:44 UTC, Joshua O'Leary
Details
View of help>about showing version info (142.35 KB, image/png)
2012-01-04 09:44 UTC, Joshua O'Leary
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua O'Leary 2011-09-11 04:43:04 UTC
As in upstream bug on launchpad:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/846381
Letters of Fontwork such as 'O' appeared coloured in on slideshow mode, if they use gradient or bitmap. This only happens when hardware acceleration (anti-aliasing) is enabled, however without this fontwork is blocky with jagged edges. Fontwork shadows are also distorted in slideshow mode. This happens in all Libreoffice versions.
Comment 1 Joshua O'Leary 2011-09-11 04:45:03 UTC
Created attachment 51047 [details]
File showing the bug in impress.
Comment 2 Christopher M. Penalver 2011-09-11 06:35:24 UTC
WORKAROUND: Turn off Hardware Acceleration via Tools -> Options -> LibreOffice -> View -> uncheck Use Hardware Acceleration -> OK button
Comment 3 Björn Michaelsen 2011-12-23 12:34:45 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 Joshua O'Leary 2011-12-24 01:37:23 UTC
This bug still exists in the 3.5.0beta2 dev release of libreoffice.
Comment 5 Christopher M. Penalver 2012-01-04 01:01:24 UTC
Joshua O'Leary, unreproducible in:
LOdev 3.5.0beta2
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Microsoft Windows Vista Business 6.0.6002 Service Pack 2 Build 6002

Please reopen this bug when the following are posted to this report:
+ a screenshot of this bug from your test noted in comment #4,
+ a screenshot of the details of Help -> About.
Comment 6 Joshua O'Leary 2012-01-04 09:13:47 UTC
This bug has been filed under the Linux (ubuntu) build of Libreoffice, not the Windows build. A bug in the Linux build does not necessarily cause a bug in the Windows version, as the executable code is completely different between platforms.
Comment 7 Joshua O'Leary 2012-01-04 09:21:07 UTC
Created attachment 55118 [details]
Normal View
Comment 8 Joshua O'Leary 2012-01-04 09:21:35 UTC
Created attachment 55119 [details]
Slideshow View
Comment 9 Joshua O'Leary 2012-01-04 09:40:25 UTC
Created attachment 55120 [details]
Normal View (LoDev Beta2)
Comment 10 Joshua O'Leary 2012-01-04 09:40:52 UTC
Created attachment 55121 [details]
Slideshow View (LoDev Beta 2)
Comment 11 Joshua O'Leary 2012-01-04 09:41:28 UTC
Created attachment 55122 [details]
View of help>about showing version info
Comment 12 Joshua O'Leary 2012-01-04 09:43:48 UTC
Created attachment 55123 [details]
Normal View (LoDev Beta2) - Test case attachment
Comment 13 Joshua O'Leary 2012-01-04 09:44:17 UTC
Created attachment 55124 [details]
Slideshow View (LoDev Beta2) - Test case attachment
Comment 14 Joshua O'Leary 2012-01-04 09:44:45 UTC
Created attachment 55125 [details]
View of help>about showing version info
Comment 15 Christopher M. Penalver 2012-01-04 17:20:05 UTC
Marking Status -> NEW based on new test results from Comment #7-14.
Comment 16 Joshua O'Leary 2012-08-22 15:22:22 UTC
Found a workaround for this bug when using gradients, that you have to apply to each fontwork object in turn:

[1] Make a fontwork object and set fill to gradient
[2] On the object:
    Right-click>Area...>Area>Untick 'Automatic' under 'Increments.
Comment 17 vulcain 2013-01-17 22:11:48 UTC
On Ubuntu 12.04.1 x86_64
Reproduce with Libre LibreOffice 3.5.7.2 Version ID : 350m1(Build:2)
Don't Reproduce with LibreOffice 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0)
Comment 18 QA Administrators 2015-02-19 15:44:09 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 19 Buovjaga 2015-03-08 19:38:16 UTC
Not reproduced -> WFM.
Comment 17 also did not reproduce.

Ubuntu 14.10 64-bit 
Version: 4.4.1.2
Build ID: 40m0(Build:2)
Locale: en_US