Bug 40950 - Combobox in RTL UI display pull down button on the wrong side
Summary: Combobox in RTL UI display pull down button on the wrong side
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
: 42078 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-16 15:14 UTC by Shahar Or
Modified: 2013-02-23 20:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
an example of the format->page window in LibO writer on Debian (26.61 KB, image/png)
2011-09-17 01:43 UTC, Lior Kaplan
Details
Drop down arrow near comobo boxes in RTL UI (60.28 KB, image/png)
2011-11-28 16:05 UTC, Lior Kaplan
Details
an example of the format->page window in LibO writer from official build (53.06 KB, image/png)
2011-11-28 16:06 UTC, Lior Kaplan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shahar Or 2011-09-16 15:14:42 UTC
Downstream Ubuntu bug report:
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/371257

Screenshot:
http://bit.ly/pVMZnM

Screenshot is self-explanatory.

Apart from the missing glyphs (another bug) some elements in the window are truncated.

I'm not sure which version this is in.
Comment 1 Lior Kaplan 2011-09-17 01:43:11 UTC
Created attachment 51281 [details]
an example of the format->page window in LibO writer on Debian
Comment 2 Lior Kaplan 2011-09-17 01:44:34 UTC
This isn't a new issue (was also reported against openoffice.org at http://openoffice.org/bugzilla/show_bug.cgi?id=107662), but it does seem to be Ubuntu specific (or at least specific to the way Ubuntu integrates LibO with GTK or something similar).

I'm attaching a screen shot of libreoffice on debian unstable (package version 3.4.3-1).
Comment 3 Rainer Bielefeld Retired 2011-11-26 23:11:11 UTC
I would really like to understand what problem we are talking about. 
In linked OOo (?!) screenshot from original report I see rectangles instead of text on the tabs, and the black border around the selection boxes is missing at the left side - the second one is the problem?

I also see the problem in the screenshot for "Bug 42078 - The buttons in combo boxes are not mirrored in RTL interface".

I can't reproduce with Farsi and Arabic UI  using "LibreOffice 3.4.4  - WIN7 Home Premium (64bit) [OOO340m1 (Build:402)]", Win UI looks completely different and buttons are at the left end of the panes, what might be an additional bug. 


I change 
- Version to unspecified because reporter did not contribute any information and 
  original OOo bug is for OOo 3.1.1!
- OS to Linux due to report

@Shahar Or
Please check with 3.4.3 and report your results.
Can you please leave a comment in Bug 42078?
Comment 4 Rainer Bielefeld Retired 2011-11-26 23:31:19 UTC
Please ignore my nonsense comment " ... are at the left end of the panes ..."!

I believe the main problem is that the pulldown buttons are not at their place. They should be inside the box and for RTL UI they should be at the left end of the pane with the value (see ATTACHED screenshot)
But in the linked screenshot the buttons are outside the box and at the right of the value panes, what means completely misplaced.

I doubt that this is a LibO issue.

@Shahar Or
Do you agree with my conclusions?
Comment 5 Yotam Benshalom 2011-11-27 05:06:52 UTC
A note I made on bug 42078, which is probably a dup:

The problem is that the combo boxes are not fully mirrored on rtl linux - the box element is, but the buttons are not. I do not agree that the fact that it appears only on linux means that it is a linux problem. In all gtk, qt, mozilla and chromium apps the combo boxes behave as they should in a linux rtl environment. I think LibreOffice is doing something wrong here.
Comment 6 Lior Kaplan 2011-11-27 11:31:42 UTC
As I said before - this is a specific bug for Ubuntu, as it doesn't happen in Debian (and Ubuntu packages are based on Debian). Also notice this comment: https://issues.apache.org/ooo/show_bug.cgi?id=107662#c7

The squares in the Ubuntu screen shot were another bug and already fixed in the meantime (e.g. the screen shot in this bug).
Comment 7 Lior Kaplan 2011-11-27 14:05:16 UTC
*** Bug 42078 has been marked as a duplicate of this bug. ***
Comment 8 Shahar Or 2011-11-28 02:02:28 UTC
Did anyone look at the code yet?
Comment 9 Lior Kaplan 2011-11-28 16:02:30 UTC
This also happens in nightly builds (from LibO site, no with Debian's packages) on 3.5.0-dev. Editing bug title accordingly.
Comment 10 Lior Kaplan 2011-11-28 16:05:52 UTC
Created attachment 53916 [details]
Drop down arrow near comobo boxes in RTL UI
Comment 11 Lior Kaplan 2011-11-28 16:06:35 UTC
Created attachment 53917 [details]
an example of the format->page window in LibO writer from official build
Comment 12 Khaled Hosny 2011-12-05 04:09:04 UTC
This issue have been fixed in master (commits 0608cb3, d2028f9 and f8e53d7).
Comment 13 Khaled Hosny 2011-12-05 04:18:39 UTC
BTW, I fixed this before seeing this bugzilla bug, this issue have annoyed me since the first time I first used OOo and I think there are tens of bug reports about this in OOo bug tracker, all ignored.

The issue is GTK specific; in RTL mode GTK mirrors most of its widget, but OOo/LO (who is directly using low level GTK APIs to draw the widgets itself) does not take into account this mirroring which results in this mismatch. The aforementioned commits fix all the three widget I've noticed (combo box, combo box entry and spin button).
Comment 14 Yotam Benshalom 2011-12-05 04:22:32 UTC
A well-deserved hooray for Khaled is due!
Comment 15 Shahar Or 2011-12-05 04:42:55 UTC
Hooray, Khaled! And thanks for the explanation, too!
Excellent!
Comment 16 Lior Kaplan 2011-12-12 12:50:56 UTC
Confirmed with daily build. Thanks Khaled.

build info:
tinderbox: tree: libreoffice-3-5
tinderbox: pull time 2011-12-10 06:30:38
tinderbox: git sha1s
core:3d5e50860ea9375acad9c42f2aefbbf6d7a1866e