Download it now!
Bug 41044 - User setting for default date format
Summary: User setting for default date format
Status: CLOSED DUPLICATE of bug 46448
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 61338 77337 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-20 09:23 UTC by Dotan Cohen
Modified: 2017-07-19 10:35 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2011-09-20 09:23:30 UTC
Users need to be able to set their date format separately from their system locale or LibreOffice locale. There exist many reasons for this, from organizations requiring ISO8601 (YYYY-MM-DD) to personal preference to working around LO, system, and desktop environment bugs.

See these related OpenOffice.org bugs to understand just how important this issue is:
http://openoffice.org/bugzilla/show_bug.cgi?id=5556
http://openoffice.org/bugzilla/show_bug.cgi?id=30216
http://openoffice.org/bugzilla/show_bug.cgi?id=72229
http://openoffice.org/bugzilla/show_bug.cgi?id=72324
http://openoffice.org/bugzilla/show_bug.cgi?id=116791
Comment 1 Dotan Cohen 2011-09-20 09:23:53 UTC
As a technical consultant, I have lost more OOo and LO users to this bug than to almost any other FOSS bug, with the possible exception of another OOo/LO date bug:
https://bugs.freedesktop.org/show_bug.cgi?id=41042

In fact, I think that this bug might be a suitable workaround for that bug as well!
Comment 2 Björn Michaelsen 2011-12-23 12:34:31 UTC Comment hidden (obsolete)
Comment 3 Dotan Cohen 2012-01-10 22:56:34 UTC
This bug is still valid for the latest development version of LibreOffice. Moving to NEW status. Thank you.
Comment 4 dotancohen 2013-09-11 06:47:29 UTC
Possibly related:
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=61338
Comment 5 Glen Peterson 2014-02-07 20:01:18 UTC
Confirmed that this bug still exists in LibreOffice Calc Version: 4.1.3.2 Build ID: 410m0(Build:2).  Probably for Y2K reasons, Excel 2010 auto-corrects 2-digit years to 4-digit.  Especially now with dates like 10/11/12 and 12/11/10 being commonplace and international data sharing on the rise, this format is horribly ambiguous.

I notice that bugzilla where I'm reporting this bug uses the 1988 ISO 8601 international standard date format: YYYY-MM-DD.  This is the only unambiguous international date format.  My first choice is to make YYYY-MM-DD the default format for LibreOffice, regardless of system locale.  Second choice is to default to (and/or auto-correct to) 4-digit years for all other formats.
Comment 6 Glen Peterson 2014-02-07 20:14:56 UTC
I'm using LibreOffice Calc Version: 4.1.3.2 Build ID: 410m0(Build:2) on 64-bit Ubuntu 13.10.  I have set my locale to English (USA).

Steps to Reproduce:
 - Open LibreOffice Calc
 - Click in a cell in a blank spreadsheet
 - Type in 3/3/2013
 - Press Enter
 - Watch cell change to 03/03/13

The same thing happens if the locale is English (UK) - the month and day are reversed, but the year still shows up in 2 digits even if I type in 4.  This is very ambiguous when people from the US and Europe (or really the rest of the world) share files.

I'm marking the following (closed) bug as a duplicate:
https://bugs.freedesktop.org/show_bug.cgi?id=61338
Comment 7 Glen Peterson 2014-02-07 20:15:15 UTC
*** Bug 61338 has been marked as a duplicate of this bug. ***
Comment 8 Glen Peterson 2014-02-07 21:57:14 UTC
I just verified this bug exists on Windows 7 Home Premium SP1 32-bit with a clean install of LibreOffice Version: 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

I followed the steps from my previous comment to reproduce the issue.

I'm setting the Version to 3.5.0 because that is the latest one that this bug could have been noticed in given the age of this ticket.  But it references 5 bugs from OpenOffice, so I'm guessing that it's always behaved this way.
Comment 9 halreads 2014-05-03 01:07:03 UTC
1. absent a template, is there a way to change the default date format
2. when a date is inserted into a Libre Office document, shading appears beneath it. Can that be changed to no shading?
Comment 10 Eric L. 2014-10-09 12:45:30 UTC
Issue still in 4.2.6.3 on RHEL6 (internal build)
Comment 11 Cor Nouws 2015-02-03 16:50:01 UTC
*** Bug 77337 has been marked as a duplicate of this bug. ***
Comment 12 sophie 2015-02-09 15:39:12 UTC
Hi, under Tools > Options > Language settings > Language, you can add your own date patterns since 4.3 (I think). So closing - Sophie
Comment 13 azamyn 2015-05-29 05:08:52 UTC
(In reply to sophie from comment #12)
> Hi, under Tools > Options > Language settings > Language, you can add your
> own date patterns since 4.3 (I think). So closing - Sophie

can i just reopen this or how should i go about with it?

i'm using libre office 4.4.3.2. my locale date pattern is D/M/Y. when i key in 24/1/15 (24 jan 2015) calc display 01/24/15 (mm/dd/yy) which is the correct date but in unfavourable format.

but when i key in 2/1/15 (2 jan 2015) calc gives 02/01/15 (mm/dd/yy, thus 1 feb 2015) which not the date intended.

so i can say the solution mentioned is not valid.

also, the default cell format and the date format in the formula bar should be able to be adjusted. adjustability should not be limited to date input pattern. otherwise, users will keep getting confused.
Comment 14 Buovjaga 2015-10-09 18:16:54 UTC
Bug does not meet the criteria for Status 'REOPENED'
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/REOPENED#Criteria
Status -> RESOLVED WORKSFORME
Comment 15 kalle 2017-07-13 18:43:22 UTC
Marking as NEW (again).

As I understand it, this bug (as reported) is a request to implement a setting for a default *display* format for dates. Unless I'm mistaken, such a feature still does not exist.

Comment 12 refers to the date *input* pattern preference, which has nothing do with the bug at hand. Thus, the bug was incorrectly marked as resolved.

Let me clarify the issue:

Currently, when a date is entered into a cell that doesn't have explicit formatting applied, the date is formatted according to the current locale. There are a few problems with this:

(1) There are countless of situations where a locale-dependent customary format is simply not suitable and a standard format such as ISO 8601 is required. This is a spreadsheet program after all.

(2) The locale-specific formats always seem to have two-digit years, which is not what most people want, even if they are happy with the customary format per se.

(3) Changing the locale affects a host of other things, too, such as the parameter separators in formulas. For this reason, some users may prefer to stick with the default locale even if it doesn't reflect their country or working language.

The obvious way to fix this would be to provide a preference for a default format string alongside the input acceptance patterns.

The two-digit year issue should be addressed separately. The current default behavior is not good, regardless of whether there's a setting to override the default format or not.
Comment 16 Eike Rathke 2017-07-19 10:35:32 UTC

*** This bug has been marked as a duplicate of bug 46448 ***