Bug 41067 - : Graphic object broken, hyperlink does not work
Summary: : Graphic object broken, hyperlink does not work
Status: RESOLVED DUPLICATE of bug 79604
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-20 23:22 UTC by Rainer Bielefeld Retired
Modified: 2015-05-13 10:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test Kit with source Documents and results (41.99 KB, application/x-zip-compressed)
2011-09-20 23:25 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-09-20 23:22:23 UTC
Steps how to reproduce with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]":

1. Open new Writer document
2. Draw Rectangle
4. Double click on rectangle, Type some short text
5. select a word in the text
6. Insert WEB link using toolbar icon / dialogs
7. Try to click link, it will lead to web page as expected
8. Click on Rectangle in document to select it
   Control points will appear
9. <Control+c> for copy
10. open new Writer document
11. <Control+v> for paste
    Rectangle with text and hyperlink appears
12. Try to click link
    Expected: will lead to web page
    Actual: nothing or focus on page jumps or some element of the
            WRITER page will be selected

- Reported with Bug Submission Assistant -
Comment 1 Rainer Bielefeld Retired 2011-09-20 23:25:50 UTC
Created attachment 51443 [details]
Test Kit with source Documents and results

SCREENSHOT COMMENT
Comment 2 Rainer Bielefeld Retired 2011-09-21 00:23:08 UTC
Comment on attachment 51443 [details]
Test Kit with source Documents and results

You can also see the problem with attachment from referring OOo Bug, so it seems to be an OOo heritage.
Comment 3 sasha.libreoffice 2012-02-03 04:25:53 UTC
in LibO 3.3.4 and 3.6.0 master on Fedora 64 bit
In Writer:
problem appears with step 7 : nothing happens when click or Ctrl-Click
In Draw no problem, change component to Writer
Comment 4 Rainer Bielefeld Retired 2012-02-03 08:33:31 UTC
I doubt that this problem affects many users, but who knows ...

Please feel free to reassign (or reset Assignee to default) if it’s not your area. Please set Status to ASSIGNED if you accept this Bug.
Comment 5 Harald Koester 2014-03-26 15:01:00 UTC
Problem at Step 7 still exists in Version 4.2.2.1.
Comment 6 Joel Madero 2015-05-02 15:44:30 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 7 Harald Koester 2015-05-13 10:26:49 UTC

*** This bug has been marked as a duplicate of bug 79604 ***