Download it now!
Bug 41143 - Bar chart for "stacked" mode is not stacking all rows
Summary: Bar chart for "stacked" mode is not stacking all rows
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 51359 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-23 02:40 UTC by Nick42
Modified: 2016-04-20 19:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick42 2011-09-23 02:40:38 UTC
Hello,

I am running LibreOffice 3.3.3 on ubuntu natty 11.04. I want to create a table+chart using
 the "column and line" chart; using the "stacked mode". It somewhat works: 
 my first rows "stack" fine; my last row shows up as "line" within the chart. But:
 the second last row data ... is simply not "stacked"; it shows up as separate column.

 I am attaching a simple ODS showing my problem.

I also created a forum entry for this; some user did some other experiments
resulting in similar odd fails:

http://en.libreofficeforum.org/node/1394
Comment 1 Björn Michaelsen 2011-12-23 12:39:50 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Nick42 2011-12-27 00:50:02 UTC
Downloaded and installed LO 3.5.0 beta2 and installed on ubuntu 11.10 test system.

I entered the following data:

Task	3Q11	4Q11	1Q12	2Q12	3Q12	4Q12
A	1	1	0	0	0	0
B	0	2	2	0	0	0
C	0	0	4	2	0	0
D	0	0	0	1	1	0
E	0	0	0	0	1	2
F	0	1	1	1	1	1
G	7	5	2	2	6	8

and found that the bug still exists: when going for "column and line chart"
the initial chart looks good.

BUT: switching to "data in rows" instead of "data in columns" row F will
not be stacked together with A to E.

CONFIRMED for 3.5

CONFIRMED for 3.4.4

Maybe someone looks finally into this bug and starts working on it?
Comment 3 ign_christian 2013-06-18 04:21:51 UTC
*** Bug 51359 has been marked as a duplicate of this bug. ***
Comment 4 A (Andy) 2015-03-07 21:24:19 UTC
Reproducible with LO 4.4.1.2, Win 8.1
Comment 5 tommy27 2016-04-16 07:28:35 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 6 Nick42 2016-04-20 06:37:33 UTC
I tried to repro the problem with LibreOffice 5.1.2.2 on Ubuntu Linux; and wasn't able to. So I assume this is fixed with newer versions of LO.