Bug 41190 - FORMATTING, FILEOPEN: no drop-down field when open docx template file
Summary: FORMATTING, FILEOPEN: no drop-down field when open docx template file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-25 11:47 UTC by Jaxson Lee
Modified: 2016-11-24 19:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
.dotx template file created in MS Word 2007 (27.79 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.template)
2011-09-25 11:47 UTC, Jaxson Lee
Details
PDF printout of how Word 2007 displays the template on opening (16.45 KB, application/pdf)
2011-09-25 11:48 UTC, Jaxson Lee
Details
PDF printout of how Writer 3.4.3 displays the template on opening (19.68 KB, application/pdf)
2011-09-25 11:48 UTC, Jaxson Lee
Details
PDF printout of how Writer 3.4.3 displays an odt file saved from the template (19.84 KB, application/pdf)
2011-09-25 11:49 UTC, Jaxson Lee
Details
How the doc looks in LO 4.1.1 (46.82 KB, application/pdf)
2013-09-29 18:48 UTC, Teo91
Details
Template exported to PDF from LibO 3.5 (29.35 KB, application/pdf)
2015-01-05 19:33 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaxson Lee 2011-09-25 11:47:49 UTC
Created attachment 51593 [details]
.dotx template file created in MS Word 2007

template_letterhead.dotx is a letterhead template designed in MS Word 2007, and saved in the default Word 2007 .dotx file format.

Not sure if one bug, or multiple small bugs is the best way of submitting this, but Libreoffice Writer has numerous issues rendering the document:

1. The heading image is rendered badly. The image inside the .dotx file (image1.png) looks to be OK, so I don't know what is causing it to be displayed this way in Writer. 

2. The heading image is moved to the top-left of the table cell. In the original document it was dragged to appear in a custom location within the cell, which is possibly what this bit of the document.xml inside the .dotx file refers to:

<wp:positionH relativeFrom="column"><wp:posOffset>1105535</wp:posOffset></wp:positionH>-<wp:positionV relativeFrom="paragraph"><wp:posOffset>451485</wp:posOffset></wp:positionV>

3. The drop-down combo-box which is meant to show before the @domain.com text isn't shown at all by Writer. In Word 2007, there is the option to choose between five different items which changes the text displayed as the first part of the email address.

4. The date has been drawn in the Times New Roman font, when it was in the Calibri font when the document was saved in Word. The theme1.xml part of the dotx file appears to be where the font detail is contained ( <a:latin typeface="Calibri"/>. )

5. is reproducible by opening the .dotx file in Writer, and then saving it as a .odt file without making any changes. Then close Writer and open the newly created .odt - the image that was in the template has now been duplicated, with a correctly rendered version showing in the top-right of the page in addition to the one still showing as described in 1. & 2. above.

PDF attachments show the display of the dotx file in Word (as it was designed) and in Writer, as well as the resulting odt created in 5.
Comment 1 Jaxson Lee 2011-09-25 11:48:29 UTC
Created attachment 51594 [details]
PDF printout of how Word 2007 displays the template on opening
Comment 2 Jaxson Lee 2011-09-25 11:48:57 UTC
Created attachment 51595 [details]
PDF printout of how Writer 3.4.3 displays the template on opening
Comment 3 Jaxson Lee 2011-09-25 11:49:41 UTC
Created attachment 51596 [details]
PDF printout of how Writer 3.4.3 displays an odt file saved from the template
Comment 4 Björn Michaelsen 2011-12-23 12:37:36 UTC Comment hidden (obsolete)
Comment 5 sasha.libreoffice 2012-02-03 05:02:25 UTC
in LibO 3.6.0 master of 1 feb 2012 on Fedora 64 bit
reproducible this:
a) email has no drop down list
b) date has font from style, in mso font name is from surrouding text
(my be not Wirter fault because in Writer field is not editable and in Word editable)
c) odt file, saved from template, has duplicated picture (reported in another bugreport)
Comment 6 Teo91 2013-09-29 18:47:33 UTC
With LO 4.1.1 on Windows 7:
- no more mistakes with the "Writer logo" inside the doc
- no more mistakes duplicate and bad placed "Writer logo" in an odt file saved from the template
But:
- still no mail drop-down list
- the page background is now BLUE (see attachment)
Comment 7 Teo91 2013-09-29 18:48:13 UTC
Created attachment 86804 [details]
How the doc looks in LO 4.1.1
Comment 8 Buovjaga 2014-10-20 10:14:00 UTC
I get the drop-down box on Win 7 64-bit 4.3.2.2 and dev build Version: 4.4.0.0.alpha0+
Build ID: 3e2bd1e4022e25b77bcc8eba5e02c1adc57008a1
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-16_01:04:13

Background is still blue, though.
Comment 9 Buovjaga 2015-01-05 19:33:57 UTC
Created attachment 111779 [details]
Template exported to PDF from LibO 3.5

In Ubuntu 14.10 64-bit and LibO 3.5, the only buggy thing is the missing dropdown box.

LibreOffice 3.5.0rc3
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 10 QA Administrators 2016-01-17 20:04:10 UTC Comment hidden (obsolete)
Comment 11 Alejandro Moreno 2016-01-18 23:07:47 UTC
Background is still blue.

Versión: 5.0.4.2
Id. de compilación: 1:5.0.4~rc2-0ubuntu1~wily1
Configuración regional: es-ES (es_ES.UTF-8)
Comment 12 Alejandro Moreno 2016-01-19 10:21:39 UTC
This bug also depens on 66397.

settings.xml has the line
<w:documentProtection w:edit="forms" w:enforcement="1"/>
that doesn't permit modify background color and this is ignored by Libreoffice.
Comment 13 Alejandro Moreno 2016-01-19 10:42:31 UTC
If you see the content of the file it contains the line
<w:background w:color="00B8FF"/> 
in document.xml that is the background color in Libreoffice. But if I open the file with MS Word I obtain that MS Word ignores that line. I could not identify because MS Office does that.
Comment 14 Telesto 2016-11-24 19:34:10 UTC
The drop-down issue seems to be fixed. That's why i'm gonna close this one. I created a new bug report related to the blue background (bug 104150).