Download it now!
Bug 41198 - Bitmaps that are scaled in one direction AND rotated, are displayed wrongly in presentation
Summary: Bitmaps that are scaled in one direction AND rotated, are displayed wrongly i...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-25 15:38 UTC by Fabian
Modified: 2015-02-20 20:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
odp matching the description and being rendered differently in edit and presentation mode (16.72 KB, application/vnd.oasis.opendocument.presentation)
2011-09-25 15:38 UTC, Fabian
Details
Screenshot of edit mode: Everything correct. (51.88 KB, image/png)
2011-09-25 15:39 UTC, Fabian
Details
Screenshot of presentation mode: Scaled AND rotaded bitmap is rendered wrongly. (132.06 KB, image/png)
2011-09-25 15:40 UTC, Fabian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian 2011-09-25 15:38:11 UTC
Created attachment 51605 [details]
odp matching the description and being rendered differently in edit and presentation mode

Rendering is different in edit ("normal") mode and presentation mode for bitmaps that are scaled in one direction and then rotated.

Rendering in edit mode is OK.
Rendering in presentation mode is WRONG: Rotation is OK, but scaling is not.

Steps to reproduce:
1) create a new, empty presentation
2) import a bitmap (a rectangle does the trick best)
3) scale it horizontally to 50%
4) rotate it 45°
5) press F5 for presentation mode

Observation:
- Edit mode: The bitmap looks as expected.
- Presentation mode: The bitmap is rotated, but scaled in both directions

Expected behavior:
Rendering is correct (and equal) in both display modes.
Comment 1 Fabian 2011-09-25 15:39:20 UTC
Created attachment 51606 [details]
Screenshot of edit mode: Everything correct.
Comment 2 Fabian 2011-09-25 15:40:32 UTC
Created attachment 51607 [details]
Screenshot of presentation mode: Scaled AND rotaded bitmap is rendered wrongly.
Comment 3 Fabian 2011-12-16 11:25:05 UTC
Still happens with current beta (Linux, AMD64):

LOdev 3.5.0 
Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4
Comment 4 Björn Michaelsen 2011-12-23 12:33:51 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Fabian 2011-12-30 01:47:58 UTC
Still happens in Beta2:

LOdev 3.5.0beta2 
Build-ID: c3bcb31-760cc4d-f39cf3d-1b2857e-60db978

Kubuntu 11.04, AMD64, Radeon proprietary graphics driver
Comment 6 A (Andy) 2013-03-24 19:33:29 UTC
reproducible with LO 4.0.1.2 (Win7 Home, 64bit)

Reproduced with the following steps:
1. Open IMPRESS
2. Copy the original rectangle with the cirle from the attachment into the new presentation
3. Right mouse click on the picture -> POSITION AND SIZE -> tab POSITION SIZE -> deactivate KEEP RATIO and reduced WIDTH to half of the original size
4. tab ROTATION -> ANGLE = 45
5. Start presentation mode

@Thorsten: Could this maybe be something for you?
Comment 7 QA Administrators 2015-02-19 15:42:04 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 8 A (Andy) 2015-02-20 20:41:53 UTC
No longer reproducible with LO 4.4.0.3, Win 8.1