Bug 41223 - FILEOPEN: Writer documents can not be opened from OS file explorer
Summary: FILEOPEN: Writer documents can not be opened from OS file explorer
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-26 05:22 UTC by Ramon Tavarez
Modified: 2012-05-04 03:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
.odt file's registry (97.99 KB, image/png)
2011-10-01 07:41 UTC, Ramon Tavarez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ramon Tavarez 2011-09-26 05:22:53 UTC
Problem description: 
Write dosn't start when trying to open a .odt file clicking on it from the File Explorer or Desktop's Shortcut.
(Such problem isn't present wiht Calc, just Writer)

I've reinstalled twice and the problem persist!

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:
File dosn't open

Expected behavior:
Open the file
Comment 1 Rainer Bielefeld Retired 2011-09-30 09:29:11 UTC
NOT reproducible with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" 

@Reporter:
Please 
- Attach a sample document (not only screenshot)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots 
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (and if possible how to created a 
  sample document from the scratch)
- add information 
  -- How you installed LibO (Server? ...?, Custom or defaut? ...")
  -- Whether .odt document are assigned to WRITER in OS
  -- what exactly is unexpected (nothing happens? Error message?)
  -- concerning your PC 
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  -- everything else crossing your mind after you read a.m. URL

- Reported with Bug Submission Assistant -
Comment 2 Ramon Tavarez 2011-10-01 07:41:25 UTC
Created attachment 51846 [details]
.odt file's registry
Comment 3 Ramon Tavarez 2011-10-01 07:42:05 UTC
OS: Windows XP Pro SP 3
LibO Version: 3.4.3
Langauge: English
LibO Starting method: Quickstarter not active.  Documents are oppened trhough the LobO's main dialog box.
Behavior:  When clicking on any . odt file's icon (at desktop or windows explorer's windows) nothing happens.  The file isn't opppened.  WRITER doesn't start. [ This behavior is NOT present with other LibO's documents: .ods. ODP, etc.]
Comment 4 Jean-Baptiste Faure 2012-01-22 10:09:39 UTC
@Ramon: do you encounter this problem with current release (3.4.5) ?
If it is the case, I suggest you to repair your installation of LO.
Did you install another office suite which may have preempted opening odt files ?

As you certainly know, you can assign odt files to LibreOffice Writer from Explorer.

Best regards. JBF
Comment 5 Ramon Tavarez 2012-01-23 04:52:25 UTC
Hi:

Happy new year!

I've installed the LO 3.4.5.  I've removed and reinstalled LO, and the
problem persist.

I have MS Office 2003, but it wan't a trouble before it begins failing.

By the moment I've been opening through File --> Open options on Writer's
menu.

I've been thinking about registries. I'll this:  remove LO suite, erease
all registries related to LO and then reinstall it (I prefer intall LO 3.5!)

Thanks for your attention.

Regards


*Ramón E. Tavárez B.*


On Sun, Jan 22, 2012 at 14:09, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=41223
>
> Jean-Baptiste Faure <jbf.faure@orange.fr> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>             Status|UNCONFIRMED                 |NEEDINFO
>                 CC|                            |jbf.faure@orange.fr
>     Ever Confirmed|0                           |1
>
> --- Comment #4 from Jean-Baptiste Faure <jbf.faure@orange.fr> 2012-01-22
> 14:09:39 AST ---
> @Ramon: do you encounter this problem with current release (3.4.5) ?
> If it is the case, I suggest you to repair your installation of LO.
> Did you install another office suite which may have preempted opening odt
> files
> ?
>
> As you certainly know, you can assign odt files to LibreOffice Writer from
> Explorer.
>
> Best regards. JBF
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 6 Rainer Bielefeld Retired 2012-01-23 07:38:58 UTC
NOT reproducible with "LibreOffice 3.4.5 German UI [Build ID: OOO340m1 (Build:502)]" in VirtualBox and WIN XP (SP1 32Bit)
 
This still is not a valid bug report.

@Ramon:
Please ask for assistance in a user mailing list, this is the wrong place for your Problem. It's definitively not a LibO problem, and you are thinking much too sophisticated, there are lots of things you should try ('WIN Task Bar -> Start -> System Settings -> Folder Options -> File Types' for example) before you do such Registry handicrafts.
Comment 7 Roman Eisele 2012-05-04 03:27:27 UTC
This is a Writer issue (or, in reality, it just looks like one; see comment #4 and comment #6), therefore changed the 'Component' field appropriately.