Bug 41354 - UI Language Tool 1.5: OOo graphics in LO
Summary: UI Language Tool 1.5: OOo graphics in LO
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-30 00:14 UTC by Marek
Modified: 2011-10-13 01:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
SCREENSHOT (32.02 KB, application/vnd.oasis.opendocument.graphics)
2011-09-30 00:14 UTC, Marek
Details
SCREENSHOT (32.02 KB, application/vnd.oasis.opendocument.graphics)
2011-09-30 00:16 UTC, Marek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marek 2011-09-30 00:14:23 UTC
Problem description: not really a bug but rather an oddity - OOo graphics (seagulfs on blue background) in LO Writter spellchecker dialog box.

Steps to reproduce:
1. Misspell any word (eg. iquwehf)
2. Press F7
3. Enjoy the old OOo graphics in the upper part of the spellchecker window (if no mistake was made ther will be no OOo grapfics)

Current behavior: displays old OOo graphics

Expected behavior: no OOo graphics or LO graphics instead

By the way the bug assistant (www.libreoffice.org) keeps stating that there is no writer component under LibreOffice ;P
Comment 1 Marek 2011-09-30 00:14:45 UTC
Created attachment 51786 [details]
SCREENSHOT

SCREENSHOT COMMENT
Comment 2 Marek 2011-09-30 00:16:21 UTC
Created attachment 51787 [details]
SCREENSHOT

SCREENSHOT COMMENT
Comment 3 Rainer Bielefeld Retired 2011-09-30 04:08:49 UTC
[Reproducible] with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" 

I am pretty sure that this one is a DUP of "Bug 32147 - Remove OOo artwork in Spelling and in Thesaurus dialogs"

@Reporter:
please contribute information 
- concerning your OS (Version, Distribution, Language) incl settings
- selected LibO Theme
- other Libo settings that might be related to your problems
- concerning your LibO version and localization (UI language) (I doubt that it's
  3.4.3!)
Comment 4 Rainer Bielefeld Retired 2011-10-10 22:56:33 UTC
My mistake, wanted to write "NOT reproducible] with LibreOffice 3.4.3"
Comment 5 Marek 2011-10-12 00:07:09 UTC
(In reply to comment #4)
> My mistake, wanted to write "NOT reproducible] with LibreOffice 3.4.3"

It is reproducible under LO 3.4.3 (in both thesaurus and spellcheck) at least under Win XP (havn't check at home under Win 7).

I use the official LO distribution with polish settings and polish (off-line) help pack. The icon theme is Galaxy (default). Other settings: dunno which might interfere perhaps only LanguageTool 1.4.

And this is LO 3.4.3 OOO340m1 (Build:302) - according to the Help > LibreOffice - Information.
Comment 6 Marek 2011-10-12 23:50:34 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > My mistake, wanted to write "NOT reproducible] with LibreOffice 3.4.3"
> 
> It is reproducible under LO 3.4.3 (in both thesaurus and spellcheck) at least
> under Win XP (havn't check at home under Win 7).
> 
> I use the official LO distribution with polish settings and polish (off-line)
> help pack. The icon theme is Galaxy (default). Other settings: dunno which
> might interfere perhaps only LanguageTool 1.4.
> 
> And this is LO 3.4.3 OOO340m1 (Build:302) - according to the Help > LibreOffice
> - Information.

It occurs that the LO is not the guilty one. Under plain user profile there is no OO graphics neither in spelchecker nor in thesaurus window. Finally I have found that the "bug" was caused by LanguageTool extention. The graphic keeps appearing also in the newest version of this extention.

It would be advisable to ask the creators to skip the graphic and render this extension version independant.

Please feel free to close this bug submission.
Comment 7 Rainer Bielefeld Retired 2011-10-13 01:01:24 UTC
I tried to submit a bug in SF Bug tracker and informed the programmers by Email.