Download it now!
Bug 41511 - Zooming in multiple pages view changes the pages displayed
Summary: Zooming in multiple pages view changes the pages displayed
Status: RESOLVED DUPLICATE of bug 40465
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-06 04:39 UTC by darkdadaah
Modified: 2011-10-06 05:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description darkdadaah 2011-10-06 04:39:48 UTC
Unzooming in multiple pages mode changes the pages displayed.

To reproduce:
- open a multiple pages documents (let's say 20 pages)
- go to the page 4
- change to display multiple pages horizontally instead of just one (bottom-right, second page button next to the zoom slider)
- unzoom to display two pages (with the zoom slider) : the pages displayed on top or now the pages 7,8
- unzoom to display three pages : it is now around 10,11,12
In other words, the number of pages from the top remains unchanged (here, 4 lines of pages).

When editing a multiple pages document, one has to go back to the page one was viewing everytime the zoom changes, which is really annoying.

The proper behaviour would be to retain the focus on the page viewed (4 -> 3,4 or 4,5 -> 2,3,4 or 3,4,5 or 4,5,6, and back).

NB : this is independant of the place of the cursor.
Comment 1 vitriol 2011-10-06 04:48:11 UTC
Probably duplicate of Bug 40465.
Comment 2 darkdadaah 2011-10-06 05:02:34 UTC

*** This bug has been marked as a duplicate of bug 40465 ***