Bug 41781 - AUTO FILTER disappears unexpectedly if last filter range column is empty
Summary: AUTO FILTER disappears unexpectedly if last filter range column is empty
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Muthu
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-14 00:33 UTC by Rainer Bielefeld Retired
Modified: 2016-10-26 08:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Presentation with screenshots (606.21 KB, application/vnd.oasis.opendocument.presentation)
2011-10-14 00:33 UTC, Rainer Bielefeld Retired
Details
Sample document (16.65 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-10-14 00:36 UTC, Rainer Bielefeld Retired
Details
screenshot of datarange used by autofilter (39.41 KB, image/jpeg)
2011-10-14 05:14 UTC, GerardF
Details
New simple test document (10.62 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-10-14 08:11 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-10-14 00:33:42 UTC
Created attachment 52316 [details]
Presentation with screenshots

Steps to reproduce with "LibreOffice 3.4.3  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]":
1. Open spreadsheet document with named data range containing 
   Column labels, Frozen Window
2. Click Autofilter Button in column header
3. Select Autofilter
   As expected filter dialog appears
   unexpectedly Autofilter puldowwn buttons disappear in   
   column headers

This problem is not 100% reproducible, related to particular documents
Comment 1 Rainer Bielefeld Retired 2011-10-14 00:36:43 UTC
Created attachment 52318 [details]
Sample document

With mysample.ods the filter problem is reproducible for me
Comment 2 Rainer Bielefeld Retired 2011-10-14 00:38:26 UTC
Also [Reproducible] with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  d3d1481-3f8994a-2ba0a9f)]" (110909)

Might be related to "Bug 30925 - Remove filter does not work for Autofilter"
Comment 3 GerardF 2011-10-14 04:51:20 UTC
Hi,

Reproductible with LibreOffice 3.4.3 under Windows Vista.

Datarange Aktuell is defined as $Endgueltig.$A$1:$AD$122 with option "Contains column labels" checked.
Columns Y to AD are empties (without column labels).

If i change the datarange to $Endgueltig.$A$1:$X$122, i cannot reproduce.
Also, if i add labels where missing (Y1 to AD1), bug isn't reproductible.

Hope this helps.
Comment 4 GerardF 2011-10-14 05:14:20 UTC
Created attachment 52332 [details]
screenshot of datarange used by autofilter

I also noticed that range use by filter not meet range defined in Data > Define range.
Filter use the table delimited by empty row and empty column (highlighted by key Ctrl+*), this range is called _Anonymous_Sheet_DB_ instead of Datarange defined by user.
See attached screenshot.
Comment 5 Rainer Bielefeld Retired 2011-10-14 08:11:21 UTC
Created attachment 52340 [details]
New simple test document

GerardF's gave me some new ideas for additional tests. The reason for the problem seems to be the filter data range with empty column label cell for the last column. At least typing a single letter into that cell solves the problem for me in several affected spreadsheets I tested.

Steps to reproduce:
1. open attached simple spreadsheet "new_sample1.ods"
2. Select / mark A1:M40
3. Menu 'Data -> Define Dange - Name = "filterarea"
    -> More -> check "Contains Cloumn Labels" if necessary'  <OK>
   DB range name has been created
4. Save as "new_sample2.ods"
5. Menu 'Data -> Filter -> Autofilter'
   Filter buttons appear
6. For column D click filter button
7. Select 'Standard filter'
   Unexpecedly Autofilter buttons disappear
   Clicking <More> in dialog shows new range 'A1:I38' with name "_Anonymous..."
8. Quit without saving

10. Open "new_sample2.ods"
11. Menu 'Data -> Filter -> Autofilter'
    Filter buttons appear
12. type an "x" into 'M1' and <Enter>
13. For column D click filter button
14. Select 'Standard filter'
    Now the Autofilter buttons remain, everything will work as expected.

With th "x" in 'L1' instead of 'M1' the problem remains
 

@GerardF:
Very very good catch!
Comment 6 Rainer Bielefeld Retired 2011-10-14 08:26:59 UTC
My observations were not exact, a letter anywhere in the last column and filter range is enough to avoid the problem.

OOo 3.1.1 behaves the same way like LibO.
OOo 3.4 forces use of "__Anonymous_Sheet_DB__0" more consequently and seems not
to suffer from the problem.

I can't tell whether other OS will be affected.

CONFIRMED due to Comments 3,4

@sumuthu:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.

- Reported with Bug Submission Assistant -
Comment 7 QA Administrators 2014-06-25 17:37:57 UTC Comment hidden (obsolete)
Comment 8 info 2015-04-11 19:27:40 UTC
This is a duplicate of bug 63416. Header recognition is currently quite odd: a header row is recognized in autofilter only if all column headers are text, i.e. no empty cells and no numbers. Otherwise, the header row and autofilter buttons will move.

Thus, this bug is duplicate.

*** This bug has been marked as a duplicate of bug 63416 ***
Comment 9 info 2015-04-11 19:34:51 UTC
Maybe it's not a duplicate, but related. Bug 63416 is about sorting. The current issue seems to be about filtering.
Comment 10 tommy27 2016-04-16 07:28:06 UTC Comment hidden (obsolete)
Comment 11 Kevin Suo 2016-10-26 08:55:30 UTC
I do not reproduce this issue under linux with the the most recent versions:
Version: 5.3.0.0.alpha1
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; 
Locale: zh-CN (zh_CN.UTF-8); Calc: group

Since this bug is described as for Windows, but there is no response for additional testing information, I set this as RESOLVED INVALID.