Download it now!
Bug 41924 - Objects shifted in export
Summary: Objects shifted in export
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-18 03:11 UTC by Michael Zapf
Modified: 2015-03-07 14:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (9.30 KB, application/vnd.oasis.opendocument.graphics)
2011-10-18 03:11 UTC, Michael Zapf
Details
"bug_arrow.odg" - test file (7.99 KB, application/vnd.oasis.opendocument.graphics)
2013-05-03 12:09 UTC, Valdas
Details
"bug_arrow.png" - result of export (4.39 KB, image/png)
2013-05-03 12:10 UTC, Valdas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Zapf 2011-10-18 03:11:43 UTC
Created attachment 52465 [details]
Test file

When I export the attached drawing, the thick line in the attached is shifted in the export. This only occurs within Linux versions, not under Windows, and only when a selection is exported, not a full page. It also happens for different target formats and different widths of the line.
Comment 1 Valdas 2013-05-03 12:07:36 UTC
I can confirm in LibO Draw v4.0.2.2 (Build ID: 400m0(Build:2)) (Kubuntu 12.10 64bit):
 - open test drawing "bug_arrow.odg" (attached), it contains thick connector with arrow;
 - select the connector;
 - in "Export..." dialog select "Selection" and export to PNG.
As result you get picture "bug_arrow.png" (attached), where arrow of connector is off line.
Comment 2 Valdas 2013-05-03 12:09:49 UTC
Created attachment 78807 [details]
"bug_arrow.odg" - test file
Comment 3 Valdas 2013-05-03 12:10:46 UTC
Created attachment 78808 [details]
"bug_arrow.png" - result of export
Comment 4 QA Administrators 2015-03-04 02:18:21 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 5 Jean-Baptiste Faure 2015-03-07 14:56:59 UTC
Not reproducible for me with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64.

Closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF