Bug Hunting Session
Bug 42078 - The buttons in combo boxes are not mirrored in RTL interface
Summary: The buttons in combo boxes are not mirrored in RTL interface
Status: RESOLVED DUPLICATE of bug 40950
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-20 18:43 UTC by Yotam Benshalom
Modified: 2011-11-27 14:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Unmirrored combo box buttons in rtl ui under ubuntu 11.10 (26.23 KB, image/png)
2011-10-20 18:43 UTC, Yotam Benshalom
Details
Correct behaviour: combo box buttons attached to the logical ending of input area (the right ending in ltr env) (40.59 KB, image/png)
2011-11-27 08:38 UTC, Yotam Benshalom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yotam Benshalom 2011-10-20 18:43:25 UTC
Created attachment 52610 [details]
Unmirrored combo box buttons in rtl ui under ubuntu 11.10

Using ubuntu Oneiric with the Ambiance, its default gtk3 theme, the buttons of combo boxes are not mirrored when working with an RTL interface. 

This is confusing when two combo boxes are adjacent, because the user would expect to open the combo box to the right of the button but will open instead the one to its left.

See attached screenshot.
Comment 1 Yotam Benshalom 2011-10-20 19:09:06 UTC
This problem exists with all gtk3 themes, not only with Ambiance. Moreover, it was reported years ago by another user and got no response:

http://openoffice.org/bugzilla/show_bug.cgi?id=70152
Comment 2 Yotam Benshalom 2011-10-20 19:13:13 UTC
Here is another bug which was opened because of the same problem:
http://openoffice.org/bugzilla/show_bug.cgi?id=107662

I allow myself to confirm the bug.
Comment 3 Rainer Bielefeld Retired 2011-11-26 23:15:17 UTC
@Yotam Benshalom
The problem is that the asymmetric pulldown arrow buttons should have the 	angular corners to the white input pane, and the rounded corners away from the input pane?

Something completely different:
Can you please leave a comment in "Bug 40950 - Truncated elements in dialog he_IL and probably all RTL"? I see the problem reported there in your screenshot, but I can't reproduce it with WIN.
Comment 4 Rainer Bielefeld Retired 2011-11-26 23:31:22 UTC
@Yotam Benshalom:
I believe this one is a DUP of Bug 40950, what had a misleading Summary. Do you agree with my Comment 4 there?
Comment 5 Yotam Benshalom 2011-11-27 05:03:48 UTC
I am very happpy to see that this gets attention - this is the main thing which holds me from using Hebrew interface :)

This indeed seems to be a dup of bug 40950. But I do not agree that the fact that it appears only on linux means it is a linux problem. In all gtk, qt, mozilla and chromium apps the combo boxes behave as they should in an rtl environment. I think LibreOffice is doing something wrong here.
Comment 6 Yotam Benshalom 2011-11-27 07:48:08 UTC
For your first question: yes, the problem is that asymmetric pulldown arrow buttons should have the angular corners to the white input pane, and the rounded corners away from the input pane. But there is more to it. Even when the buttons themselves are symmetrical (which is theme-dependent), they will appear detached from the box element to which they apply, as long as they are not properly mirrored.
Comment 7 Yotam Benshalom 2011-11-27 08:36:24 UTC
Oh! I just noticed something.

When comparing the combo boxes in rtl interfaces to combo boxes in ltr interfaces, I can see the the buttons actually WERE mirrored correctly. The problem is that they WERE NOT MOVED to the left of the input area, because they are mistakenly treated like an independent element.

I attach a screenshot of the situation in ltr environment. As you can see, the buttons are attached to the logical "ending" of the input area, i.e. to the right. The same should happen in Hebrew: they should be attached to the left.
Comment 8 Yotam Benshalom 2011-11-27 08:38:02 UTC
Created attachment 53885 [details]
Correct behaviour: combo box buttons attached to the logical ending of input area (the right ending in ltr env)
Comment 9 Lior Kaplan 2011-11-27 14:05:16 UTC

*** This bug has been marked as a duplicate of bug 40950 ***