Bug 42101 - Base report and form windows drawn distorted
Summary: Base report and form windows drawn distorted
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-21 14:18 UTC by lpietsch
Modified: 2011-10-23 13:19 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Form design window in LibreOffice base. Position of window border is off by about 4 cm horizontally and 1 cm vertically from position of window contents. (76.14 KB, image/png)
2011-10-21 14:18 UTC, lpietsch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lpietsch 2011-10-21 14:18:13 UTC
Created attachment 52620 [details]
Form design window in LibreOffice base. Position of window border is off by about 4 cm horizontally and 1 cm vertically from position of window contents.

This is LibreOffice 3.4.3 on the current release of Xubuntu (11.10 "Oneiric"). In all daughter windows displaying forms or reports, the window contents are drawn displaced from the window borders by an offset of several centimeters, in random directions. The window contents thus occupy a space that overlaps, and partly obscures, the space occupied by the window border and title bar. Both the window contents and the functional elements of the title bar (dragging, resizing, max/min buttons) remain functional to the extent that they are not obscured, but the effect is so distracting as to make the whole program virtually unuseable.
Comment 1 lpietsch 2011-10-21 14:40:15 UTC
Update: Problem no longer reproducible after complete de-install and reinstall of Libreoffice. Very strange.
Comment 2 lpietsch 2011-10-23 13:19:22 UTC
Turns out this happens when one installs Base in Xubuntu without the "libreoffice-gtk" package. Happens easily enough, but probably more an issue with poor packaging in the distro than a "bug"