Bug 42121 - BUGZILLAASSISTANT: sometimes submission process does not start, remains before Step 1
Summary: BUGZILLAASSISTANT: sometimes submission process does not start, remains befor...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
(earliest affected)
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Reported: 2011-10-23 01:33 UTC by Rainer Bielefeld Retired
Modified: 2013-03-16 06:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

Wiresharkprotocol.pcap (708.94 KB, application/octet-stream)
2011-11-11 09:25 UTC, Rainer Bielefeld Retired

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-10-23 01:33:27 UTC
Steps how to reproduce:
1. Open <https://www.libreoffice.org/get-help/bug/> in Browser 
   Expected: Sign in Window (Step 1)  or Step 2 appears
   Actual: Nothing

Might be a remaining problem from "Bug 41832 - BUGZILLAASSISTANT: same origin policy problem prevents user feedback"?

Submission works fine when I start on <http://www.libreoffice.org/> and then click 'GetHelp -> Bug'
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20110928 Firefox/7.0.1 SeaMonkey/2.4.1
Comment 1 Rainer Bielefeld Retired 2011-10-23 01:35:14 UTC
Can you please check?

- Reported with Bug Submission Assistant -
Comment 2 Loic Dachary 2011-10-23 02:48:43 UTC
I was able to fill
I took a screenshot of the first page
Would you be so kind as to let me know exactly which OS version and browser you are using so that I can reproduce the failure ?
Comment 3 Rainer Bielefeld Retired 2011-10-23 21:59:10 UTC
The problem today was reproducible for me  08:35 UTC with German WIN7 64Bit and Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20110928 Firefox/7.0.1 SeaMonkey/2.4.1.

1 minute later no longer reproducible with IE8 32 Bit and FF 7.0.1 and also no longer with Seamonkey. 

Can it be that the pattern I thought to see only was accidently, and in reality the problem is "random controlled"? I will test from time to time.
Comment 4 Loic Dachary 2011-10-24 09:37:41 UTC
I can't imagine any reason why it would happen randomly.
Comment 5 Rainer Bielefeld Retired 2011-10-24 10:56:24 UTC
Me too. Seems that the reasons were outside BUGZILLAASSISTANT. After 1 mishap in the morning all other (20 ... 30) attempts were successfull, I close the bug for now.
Comment 6 Rainer Bielefeld Retired 2011-11-03 23:50:29 UTC
I still suffer from this problem, very much more often than I have to wait for reaction directly in Mozilla, and it seems mostly when I directly use y bookmark to  <https://www.libreoffice.org/get-help/bug/> directly from Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20110928 SeaMonkey/2.4.1
Comment 7 Rainer Bielefeld Retired 2011-11-04 00:15:25 UTC
A good workaround is to start Wireshark before starting the Assistant, I never see the problem with running W. ;-)
Comment 8 Loic Dachary 2011-11-04 01:10:27 UTC
At the moment it is difficult to imagine why it happens. The wireshark workaround is interesting. Could you confirm that you experience this behavior since the time the ticket was closed ? Also it would help if you know that it happens one time out of ten or one time out of two. Does it happen every day ? Or are there days without the problem ?
Comment 9 Rainer Bielefeld Retired 2011-11-11 08:12:10 UTC
My workaround does not work reliably ;-)
So I have a Wireshark protocol, Loic, do you believe that might be useful?
Comment 10 Loic Dachary 2011-11-11 08:34:04 UTC
Yes, please post it.
Comment 11 Rainer Bielefeld Retired 2011-11-11 09:25:09 UTC
Created attachment 53413 [details]

Wireshark protocol as requested. Ther might be some dirt in it, I did not close all my other programs, but I filtered "host:libreoffice.org"
Comment 12 Lionel Elie Mamane 2012-01-19 00:59:52 UTC
This looks similar to bug 43289
Comment 13 Rainer Bielefeld Retired 2012-01-19 01:14:22 UTC
Yes, at least the result ("does not start") is the same. For me it 's not 100% reproducible and might be related to the way I reach the assistant. But all this still is more assumption than reliable result of research.
Comment 14 Mike §chinagl 2012-01-19 02:01:16 UTC
I cannot reproduce this bug under XP SP3 German with Firefox 9.01
Comment 15 Rainer Bielefeld Retired 2012-01-19 02:02:03 UTC
Loic currently is not active in the project.

To clarify: Generally I am already logged in when I start submission process because I forgot to log out after the session before.
Comment 16 s-joyemusequna 2012-01-19 03:14:43 UTC

I had the problem 2 or 3 times (Firefox 9.0.1 and Windows Vista 64). I then tried to go to Bugzilla directly, without the Bug Report Assistant, but Bugzilla was frozen every time, so I thought Bugzilla was the problem.
Comment 17 Harald Koester 2012-01-19 05:26:38 UTC

I had a problem with the Bug Submission Assistant (BSA) too some weeks ago. Then I
went to Bugzilla directly in order to submit a bug. As I remember it works.

I assume that the use of the BSA is marked in the field "Whiteboard" with "BSA". I checked the Whiteboard field of my submitted bugs in order to get the dates when the BSA did not work. The dates are 2011-10-20 and 2011-11-23. 

(Firefox 3.6.x and Windows XP)
Comment 18 Rainer Bielefeld Retired 2012-01-19 05:40:34 UTC
One additional info: I believe "Bug 44441 - Gateway Time-out" also affected the Assistant. So only problems with Assistant that appeared while direct Bugzilla access was possible are of interest here.
Comment 19 Li Chong 2012-01-19 07:07:17 UTC
Nope. I don't have any problem. Mozilla Firefox 9.1 and Ubuntu Linux 10.04
Comment 20 h8999 2012-01-19 08:37:09 UTC
Responding to your mail.
If I remember right, I did have a problem when I reported bug 44026, but don't remember if it was the same. Actually I did not pay any attention because there was an alternate way of reporting the bug.

Simulated a bug reporting today, got up to step 5 without a problem.
Browser: Mozilla/5.0 (X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
under Suse 12.1
Comment 21 Rhodes 2012-01-19 10:02:33 UTC
No submission problem here, with Safari 4.1.3 on Mac OS X 10.4.11. Email response was slower (a month) than two previous bugs, but I attribute that to the 3.5.0 beta work.
Comment 22 pieter kristensen 2012-01-19 10:16:08 UTC
I think I used Kubuntu 11.10 32bit firefox to file my bug. But to do that I had to create a freedesktop account. This turned out to be very easy but with all things happening at that time I have not looked at the assistant so well.
I can't answer your question. Sorry.
But all is well that ends well, the bug is filed!
Comment 23 Andrew Pitonyak 2012-01-19 14:47:43 UTC
This fails for me if I go in with the URL listed


If I remove the trailing "/", then this works just fine


Note that I am running Firefox on top of 64-bit Fedora.
Comment 24 Paul Rolfe 2012-01-19 15:22:57 UTC
It worked fine for me - using Google Chrome 10.0.648.205, on Suse Linux 11.4
Comment 25 Rainer Bielefeld Retired 2012-01-19 21:19:11 UTC
Although I can't reproduce your result 100% (Browser cache effects might have some influence), that's a good point and would explain my observation why that problem seems to depend on the way how I reach the assistant
Comment 26 novotnyw 2012-01-20 02:19:00 UTC
Basicly the same problem here, but only at first try, when write full path in address bar. Since I went succesfully through libreoffice.org -> GetHelp -> Bug, everything works just fine. I remember that I had this problem one week ago, when I filled some other bug report and I went at that page from Google search. I dont remember exactly how, but after some tinkering I succeeded to proceed.

Running Google Chrome 16.0.912.75 under Debian Squeeze x86-32
Comment 27 Jean-Baptiste Faure 2012-02-04 15:25:13 UTC
No problem for me with FF under Ubuntu 11.10, BZ assistant start always at step 2 for me.

Best regards. JBF
Comment 28 Rainer Bielefeld Retired 2012-03-11 05:27:57 UTC
I also sometimes see this problem using the new "Feedback" link in LibO Help menu.
Comment 29 Rob Snelders 2013-03-15 20:53:14 UTC
Does anybody still get's this problem?

I haven't seen it.
Comment 30 Rainer Bielefeld Retired 2013-03-16 06:07:10 UTC
I did not see that for a long time