Download it now!
Bug 42127 - VIEWING: choppy scrolling in .ODG file
Summary: VIEWING: choppy scrolling in .ODG file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: perf
Depends on:
Blocks:
 
Reported: 2011-10-23 06:28 UTC by Carla sella
Modified: 2017-01-15 15:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
A draw document used to draw network configuration (20.43 KB, application/vnd.oasis.opendocument.graphics)
2011-10-23 06:28 UTC, Carla sella
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carla sella 2011-10-23 06:28:17 UTC
Created attachment 52650 [details]
A draw document used to draw network configuration

Problem description: 

Steps to reproduce:
1. open attached document (MyNet.odg)
2. try to scroll it up and down


Current behavior:
It's very slow and screen on Ubuntu 11.10 (it also happened on Ubuntu 11.04) goes gray for a while, it turns normal but scolling is sluggigh

Expected behavior:
Normal scrolling of document up and down and sideways

Platform (if different from the browser): 
Ubuntu 11.04 and Ubuntu 11.10 64 bit
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1


This used to happen also with Libre Office 3.3.2.

This same Libre Office Draw document opened under Windows 7 has absolutely no problem related to CPU usage and I can scroll it and work with it normally.

I have already reported a bug on launchpad:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/785397
Comment 1 Carla sella 2011-10-23 06:51:26 UTC
Sorry in he "current behaviour" section "sluggigh" stands for sluggish (it was a typing error)
Comment 2 Carla sella 2012-03-08 12:43:39 UTC
I am currently using Precise Pangolin Beta 1 with all updates installed and the problem is even worse, it's impossible to modify the document.
I really need to work on odg documents but it impossible with this bug, are you going to do something to fix it ? it's been quite a long time since the reporting of this bug.
Thanks.
Comment 3 tommy27 2013-01-03 23:26:02 UTC
I'm not a developer but I confirm that the scrolling behaviour is subotimal in 4.0.0.0.beta2+ as well (Build ID: 350ae8294a8df78403fd8cdce56b9aeb8178e13) using Vista 64bit.

however I would not call it sluggish... In my test it was choppy (in italian "scattoso")
Comment 4 QA Administrators 2015-04-01 14:40:05 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-04-19 14:58:58 UTC
I guess it is a bit sluggish or choppish.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Version: 4.5.0.0.alpha0+
Build ID: afb82d3729bda2754d0add08cc6c4dce1dc76d59
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-04-14_00:05:04
Locale: en_US
Comment 6 Robinson Tryon (qubit) 2015-12-10 02:02:50 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-01-03 19:39:57 UTC Comment hidden (obsolete)
Comment 8 tommy27 2017-01-03 23:07:19 UTC
scrolling is shill "choppy" using LibO 5.2.4.2 and 5.4.0.0 alpha

the bug is easier to reproduce if you scroll using arrowkeys
Comment 9 Carla sella 2017-01-15 15:20:57 UTC
I have tested the attached file on Window 10 with Libre Office 5.2.4.2 and the issue is solved, the file can be scrolled just fine.
On Ubuntu I have Libre Office 5.2.2.2 (this is the version Ubuntu installes) and also there the issue is gone, everything is ok.

Carla