Bug 42139 - PDF export adopts the theme of the Desktop Environment
Summary: PDF export adopts the theme of the Desktop Environment
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-23 15:10 UTC by Alexandro Colorado
Modified: 2015-01-25 06:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Shot of a Draw document on Okular. (157.90 KB, image/png)
2011-10-23 15:10 UTC, Alexandro Colorado
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandro Colorado 2011-10-23 15:10:30 UTC
Created attachment 52664 [details]
Shot of a Draw document on Okular.

When exporting a document to PDF it grabs the UI theme of the Application layer. So doing a high level theming of the Desktop Environment. LibreOffice will adjust itself to the Theme all the way to the document. 

The issue comes when the PDF export will generate a PDF with the theming. This works bad when your document is a traditional white color paper generate a dark background with light gray document in PDF.
Comment 1 Alexandro Colorado 2011-10-23 15:12:54 UTC
Correct component to PDF export.
Comment 2 Panda 2012-06-20 11:19:31 UTC
I can confirm this bug on Windows XP with LibreOffice 3.6 beta 1 and Ubuntu 12.04 with LibreOffice 3.5.3.2.
Comment 3 QA Administrators 2015-01-05 17:51:52 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
Comment 4 Buovjaga 2015-01-23 18:32:12 UTC
I can't reproduce, but I don't get a dark background in Draw with a dark theme (Ambiance-Blackout).

Ubuntu 14.10 64-bit
Version: 4.3.3.2
Build ID: 430m0(Build:2)
Comment 5 Adolfo Jayme 2015-01-25 06:15:29 UTC
This was solved in 2012 with this commit: http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d06094c701262ef54604be206c25dd87a77d224