Bug 42332 - wrong formatting of the autocorrect results
Summary: wrong formatting of the autocorrect results
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
3.4.4 RC1
Hardware: Other All
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2011-10-28 01:27 UTC by Yury
Modified: 2014-07-20 09:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

screenshot illustrating the problem (84.50 KB, image/png)
2011-10-28 01:27 UTC, Yury

Note You need to log in before you can comment on or make changes to this bug.
Description Yury 2011-10-28 01:27:46 UTC
Created attachment 52840 [details]
screenshot illustrating the problem

The autocorrect result (in my case, '--' and '---' replacement) may happen to be (auto)styled with wrong choice of font face. 

My (uninformed) guess is this is connected with fontconfig match over certain combinations of `default basic font' setting and fonts installed on system, somehow. The data supporting this guess is:

I have 'Gentium' set as a default paragraph style font face. Now, if I start the new text, and (first thing) trigger `dash replacement' for the, e.g., '---' sequence, the result will be `character styled' with 'Gentium Plus' (as shown in screenshot).

Same may happen if the default paragraph style font face is changed in the document -- autocorrected sequences formatted to something different. 

The result: hard-to-explain uneven line spacings.

The suggested correction: for the auto-corrected sequence to introduce NO separate formatting, to comply with the rest of the paragraph.
Comment 1 Yury 2011-12-11 22:32:21 UTC
After some prodding, I'm confused even more. My guess is there's a possibility of corrupted/nonstandard auto-correct entry being retained by LibO somewhere in configuraton files.

I was able to remedy the problem by deleting and re-creating the `--- for [All] languages' entry, but I believe the potential for erroneous behaviour remains there.


As far as grep could tell, before the entry deletion and re-creation there was no specific mention of 'Gentium Plus' anywhere in my config files (excepting the pspcache, of course), or in system-wide config files. However, at least *some* auto-correct entries still were being formatted with 'Gentium Plus', specifically, the '---' to emdash conversion. Incidentally, said '---' entry was being shown in dialog with blank char as a replacement but emdash (in 'Gentium Plus') was actually being substituted?..

Here's what wordbook/standard.dic looked like, and still looks like (the 5th line was and is empty):
lang: <none>
type: positive

There was no mention of '---' anywhere else.
Comment 2 Yury 2012-10-01 06:49:38 UTC
BTW, this is connected somehow with an option of "insert text only" being selected or not. This checkbox, if checked (which is not a self-evident action), eliminates the problem, but where does the not-text-only style come from, then?
Comment 3 Yury 2012-10-17 08:55:45 UTC
Also, the "text only" checkbox might be at times grayed out (so, uncontrollable).
Comment 4 Jean-Baptiste Faure 2014-01-26 13:51:21 UTC
Not reproducible for me.
This bug report has never been independently confirmed. So set back to unconfirmed.

Best regards. JBF
Comment 5 Thomas Hackert 2014-03-09 15:35:21 UTC
Hello Yuri, *,
I cannot confirm your bug with LO Version: Build-ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f with installed Germanophone lang- as well as helppack on Debian Testing i386, sorry ... :(

Would you be so kind to give us a step-by-step instruction, please? Where did you change the language: In the "Styles and Formatting" window? In the font selector of Writer? Or somewhere else? I have tried both, and when the autocorrection changes something like quotation marks or a dash to an em dash, and I mark them afterward, they are using the font, which I have chosen for the document ... ;)

Have you tried it with a newer version of LO than 3.4.4RC1? Does your problem still occurs there? And have you renamed/removed your user dictionary, before you tested it again? Did you – by any chance – use an extension, which may interfere here (maybe LanguageTool, maybe something else)?

And would you be so kind to mention your OS/architecture/version here as well?
Thanks in advance and sorry for the inconvenience
Comment 6 Yury 2014-03-09 16:28:43 UTC
The initial problem IIRC was that I couldn't get non-textonly (styled) auto-corrections in defined style -- the style actually used was being taken from unknown location/setting.

I can't even attempt to reproduce the problem today on the build 70feb7d99726f064edab4605a8ab840c50ec57a -- the 'Text only' checkbox is set and change-disabled (grayed out).
Comment 7 Jean-Baptiste Faure 2014-07-20 09:51:41 UTC
Due to comments #5 and #6 closing as WorkForMe.

Best regards. JBF