Bug Hunting Session
Bug 42472 - Calc EDITING functionality request: add grouping of entered text in undo
Summary: Calc EDITING functionality request: add grouping of entered text in undo
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-01 05:29 UTC by Michal Suchanek
Modified: 2016-07-04 06:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Suchanek 2011-11-01 05:29:01 UTC
To reproduce

1) click a cell
2) type some text
3) press ^Z

result: a letter is undone
expected: some substantial portion of text is undone

Pressing 100x undo to get to the previous change is utterly useless and exhausts the very limited undo stack quickly.
Comment 1 sasha.libreoffice 2012-04-19 01:19:25 UTC
Thanks for bugreport
This behaviour is only in last edited cell. All previous cells undo one cell at once. This done intendedly for more easy to fix last few typed digits.
Comment 2 Michal Suchanek 2012-04-19 02:22:01 UTC
What is the use case for undoing one digit at a time?

You can just delete them with backspace.

If LO had multilevel undo (as in you could pick to undo letter at a time, a word at a time, and a cell at at time) and unlimited undo stack this would be less off an issue but as it is now undo in spreadsheet is essentially useless duplication of the backaspace key.

As undo actions are very limited they should focus on larger higher level actions, not typing single letter. Other more sensible applications split undo actions on punctuation, pauses in typing (as in pauses in user input) or they separate when input type changes (typing vs selection vs performing other actions).
Comment 3 sasha.libreoffice 2012-04-19 02:41:31 UTC
> As undo actions are very limited they should focus on larger ...
Indeed, only 999 steps, but developers working on increasing it to 10 000.

If You want to undo all changes to cell at once, just press enter and then Ctrl-Z.

In comparison, msExcel undoes all changes to cell immediately by pressing Ctrl-Z.
Comment 4 Michal Suchanek 2012-04-19 02:58:14 UTC
(In reply to comment #3)
> > As undo actions are very limited they should focus on larger ...
> Indeed, only 999 steps, but developers working on increasing it to 10 000.
> 
> If You want to undo all changes to cell at once, just press enter and then
> Ctrl-Z.

Now that's totally obvious.

As I said previously there are more sensible undo units than letters that can be used even inside single cell. Or does the Writer also undo a letter at a time? That would be equally ridiculous.
Comment 5 sasha.libreoffice 2012-04-19 03:13:14 UTC
> Now that's totally obvious.
Also obvious that Calc is not text editor but calculation program
Changing to functionality request
Comment 6 Michal Suchanek 2012-04-19 04:21:08 UTC
it's still the same office?

Why should typing in calc behave differently than typing in writer?

There is no obvious reason for that.

You type text, numbers and equations in ether writer or calc. No difference there.
Comment 7 Joel Madero 2016-07-04 06:01:19 UTC
Version: 5.3.0.0.alpha0+
Build ID: c89294233b6a9ffc1bd75e6e9226ad723b7d5538
CPU Threads: 2; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (en_US.UTF-8)


From what I can tell undo removes the entire previous word. I think that this is as far as this is going so I'm closing this as WFM.

The reason why delete and undo are different is because if you delete you add a new value to the undo chain, while if you undo, you're going back through your undo list. These are not the same.

Again, think that the current behavior is different from that described (a whole word is undone, not a single letter). It's not going any further than this so WFM.

Thanks!