Bug 42544 - Draw UI functionality request: add option for currently selected tool stay, and not change to selecting tool after each use
Summary: Draw UI functionality request: add option for currently selected tool stay, a...
Status: RESOLVED DUPLICATE of bug 39268
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.2 RC2
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-03 01:58 UTC by Glen Winters
Modified: 2016-05-25 15:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Glen Winters 2011-11-03 01:58:48 UTC
Problem description: 
It's a pain to create a bunch of connectors because after placing each connector, the cursor reverts to a Select pointer. 

Steps to reproduce:
1. Create two basic shapes:
  - Click Basic Shapes on the Drawing toolbar.
  - Click and drag on the canvas to create a shape.
  - Repeat the last two steps again so you have two shapes.
2. Click Connector on the Drawing toolbar.
3. Hover over one shape, click and hold the left mouse button, drag the cursor to the second shape, and then let go of the mouse.

Current behavior:

A connector is drawn between the two shapes and the cursor is now a Select pointer.

Expected behavior:

A connector is drawn between the two shapes and the cursor is still a connector so a second connection can be easily drawn.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

Ubuntu 10.10 64-bit with 3.1.0-rc4 kernel
Comment 1 sasha.libreoffice 2012-04-19 02:54:39 UTC
Thanks for bugreport
This problem reproducible in 3.5.2 version and not only with connectors, but with all drawing objects.

IMHO it is functionality request: Add option to stay selected object (tool) and not change to selection tool.

Workaround: assign connector on some button on keyboard. It will greatly improve productivity.
Comment 2 sasha.libreoffice 2012-04-19 03:01:45 UTC
May be such option should be possible for each tool independently because some tools (lines, arrows, connectors, rectangles) intended for multiple (repeating) use, and another tools - for drawing only once. 
Or just imitate behaviour of another well known editor, for example InkScape.
Comment 3 Glen Winters 2012-04-19 03:35:49 UTC
Yeah, it's common for me to draw a bunch of items in a row. I don't typically need the select tool during that process, so it's unnecessary to keep going back to the select tool. An option in preferences to stay with the last used drawing tool would be nice if the main functionality isn't changed.
Comment 4 Emir Sarı (away) 2013-01-24 17:57:43 UTC
This should definitely be implemented. I think this is a standard feature on most drawing applications, right? And from an UX point of view, lack of this feature is horrible IMHO.
Comment 5 Heiko Tietze 2016-05-25 15:13:10 UTC
Often reported as annoying, for instance in 39268.

*** This bug has been marked as a duplicate of bug 39268 ***