Download it now!
Bug 42612 - EDITING: double-click on a table entry when table preview mode switched on opens table data window behind main application window
Summary: EDITING: double-click on a table entry when table preview mode switched on op...
Status: RESOLVED DUPLICATE of bug 35091
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-05 00:09 UTC by heinzws
Modified: 2011-11-13 05:22 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
snapshot: document shown in preview (133.89 KB, image/png)
2011-11-06 00:43 UTC, heinzws
Details
snapshot: nothing shown in preview (82.09 KB, image/png)
2011-11-06 00:45 UTC, heinzws
Details
5 tables opened (190.81 KB, image/png)
2011-11-06 02:11 UTC, heinzws
Details
test database (3.64 KB, application/vnd.oasis.opendocument.database)
2011-11-07 05:14 UTC, Petr Mladek
Details
Screenshot better explaining 3rd step to reproduce from the comment 20 (43.62 KB, image/png)
2011-11-08 23:44 UTC, Petr Mladek
Details
experimental: disable delay (572 bytes, patch)
2011-11-09 14:34 UTC, Lionel Elie Mamane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description heinzws 2011-11-05 00:09:03 UTC
## Running Debian/testing (AMD64), MySQL, MySQL connector (1.0.1).
dbl-clicking a table opens *and* closes table at once, table doesn't stay open.
<right-click> + <open> works fine.

dbl-clicking worked in 3.4.3.
Comment 1 Rainer Bielefeld Retired 2011-11-05 04:10:25 UTC
NOT reproducible with a spreadsheet based address data base (or biblio.odb) and "LibreOffice 3.4.4RC2  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:402)]" 

@reporter:
May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport> carefully?
Then please:
- Attach a sample document (not only screenshot)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (and if possible how to created a 
  sample document from the scratch)
- add information 
  -- concerning your PC
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind after you read linked texts
Comment 2 Alex Thurgood 2011-11-05 23:56:20 UTC
Can not reproduce on Mac OSX 10.6.8, mysql connector 1.0.1.

The tables in my DB all open just fine with a double-click.

Alex
Comment 3 Alex Thurgood 2011-11-05 23:56:47 UTC
Forgot to mention that I used LO 3.4.4rc2
Comment 4 heinzws 2011-11-06 00:43:38 UTC
Created attachment 53204 [details]
snapshot: document shown in preview

Additional:
Table does  *not*  stay open when document is shown in preview [*1.png];
it stays open when nothing is shown in preview  [*2.png]
Comment 5 heinzws 2011-11-06 00:45:01 UTC
Created attachment 53205 [details]
snapshot: nothing shown in preview

see last comment
Comment 6 Alex Thurgood 2011-11-06 01:02:37 UTC
Testing with native HSLDB file gives the same results.
Comment 7 Alex Thurgood 2011-11-06 01:03:58 UTC
Tested with native HSQLDB file. Same results. Window appears briefly then disappears.
Comment 8 Alex Thurgood 2011-11-06 01:14:33 UTC
Hmm, further experimentation with a clean profile shows that the Table window is opened when Preview Mode is ON, but in the background behind the main window with the same coordinates as the main window and so does not seem to have been displayed, at least on Mac OSX. The only reason I noticed that the Tables were actually displaying is that I opened several in sequence and the window manager then shifts the window coordinates so that the edge of the window can be seen.

So if a user just opens one table, and it gets placed behind the main window, then it appears that it hasn't opened.

Can anyone else confirm this ? If this is the case, then we will have to edit the bug title.


Alex
Comment 9 Alex Thurgood 2011-11-06 01:18:23 UTC
Oh great, don't tell me that the fdo servers have just shifted back in time, so my bug reports appear to have been made in the wrong order, arragghh !!!!
Comment 10 Alex Thurgood 2011-11-06 01:24:55 UTC
OK, repeated testing shows that the Table Data windows are opened behind the main window. If the main window is full screen, the user is led to believe that his/her table wasn't displayed.

Heinz can you test this on your system please ?


Alex
Comment 11 Julien Nabet 2011-11-06 01:27:42 UTC
heinzws: 
- what's the version of Mysql server ? (5.1 ?)
- Have you tested on a new odb file or with an odb created on a former version
of LO ?
- could you please give the error messages of the console ?
- have you tested on another Mysql database ?
Comment 12 Alex Thurgood 2011-11-06 01:44:32 UTC
OK, I can reproduce now.

When the Table Preview mode is ON, then a double click on a table in the list of tables causes the table to open briefly (couple of microseconds) then close again.


How to reproduce :

LibO 3.4.4rc2
Database : Mysql
Connection : native C mysql connector extension
ODB configuration settings : in the right-hand bottom pane of the ODB Table window, switch the view from None to Document in the dropdown menu.


Confirming.

Alex
Comment 13 Alex Thurgood 2011-11-06 01:45:38 UTC
Setting OS to all, as I can reproduce on Mac, initial reporter was on Linux.
Comment 14 Alex Thurgood 2011-11-06 01:52:24 UTC
I can also reproduce on :

LO 3.4.3
LO 3.3.4

but not on master :
Build ID: e42dfec-c60ac25-41e7bcd-3b66bd0

although, on my master build the Table window opens up behind the ODB main window in this case.
Comment 15 Julien Nabet 2011-11-06 01:53:31 UTC
alex: I haven't tried to reproduce the pb for the moment because I struggle
with another bug before this one.
On 3.4.3, I installed mysql-connector, i can see the tables.
On master, updated today, it crashes when it tries to list the tables.
what's the date of your git update, I haven't found the corresponding commit ?
Comment 16 Alex Thurgood 2011-11-06 01:54:21 UTC
(In reply to comment #9)


> although, on my master build the Table window opens up behind the ODB main
> window in this case.

Systematically :-/ very annoying, I can open any amount of tables, they all get displayed behind the main ODB window (another bug, although I thought I'd already opened one for this).


Alex
Comment 17 Alex Thurgood 2011-11-06 01:55:10 UTC
removed NEEDINFO keyword
Comment 18 heinzws 2011-11-06 02:11:11 UTC
Created attachment 53210 [details]
5 tables opened
Comment 19 heinzws 2011-11-06 02:17:38 UTC
(In reply to comment #10)
> OK, repeated testing shows that the Table Data windows are opened behind the
> main window. If the main window is full screen, the user is led to believe that
> his/her table wasn't displayed.
> 
> Heinz can you test this on your system please ?
> 
> 
> Alex

Can confirm this - but not only in full screen.
I opened 5 tables. In "half-screen" they are one behind the other as well:
--> screenshot *3.png
I can toggle with <Alt> + <Tab>.

Preview mode ON: I don't see any (except by toggling  --  when I  *know*  they are there.

Heinz
Comment 20 Petr Mladek 2011-11-07 05:14:12 UTC
Created attachment 53245 [details]
test database

The problem is visible even with simple database.

Steps to reporoduce:

1. open test.odb
2. select "Tables" in the "Database" panel on the left
3. Select "Document" in the combo box in the "Table" panel in the top right 
   corner; the default value is "None"
4. Double click on the "Table1" name

Result: It shows the table values in another window. It hides the window behind the main window within 1 sec or so.

Expected Result: It shows the table values in another window. The window stays in the foreground.

Observation: I see the same behavior also with LO-3.4.3.
Comment 21 Petr Mladek 2011-11-08 23:44:06 UTC
Created attachment 53313 [details]
Screenshot better explaining 3rd step to reproduce from the comment 20
Comment 22 Lionel Elie Mamane 2011-11-09 14:32:38 UTC
Here's my theory. One or both of the symptoms is due to the fact that events happen in this order:

1) Double-click -> open table data view
2) Change of selection -> refresh preview

The "refresh preview" handling brings the database window back to the forefront, but that's after the new "table data view" window has been opened. Maybe it somehow also closes the other window in 3.4.4, not sure.

Maybe if we could switch the order of these two events? But the second event seems to be delayed by 900ms pretty much on purpose, with a timer. I'm not sure why, but that's probably for performance reasons, so that when one changes the selection often (e.g. with the down/up arrow on the keyboard), things are not too horribly slow.

I disabled the delay and confirmed it fixes (on master) the "table data view opened behind main application window" symptom. Could someone please check whether it also fixes (in 3.4.4rc2 with mysql, see comment 12) the "table data view closes after a second" symptom? I don't have access to that setup right now.
Comment 23 Lionel Elie Mamane 2011-11-09 14:34:56 UTC
Created attachment 53352 [details]
experimental: disable delay
Comment 24 Lionel Elie Mamane 2011-11-11 08:47:20 UTC
I cannot reproduce the "table data window closes" behaviour with freshly compiled libreoffice-3-4 and native mysql driver. I only get the "opens behind" behaviour".
Comment 25 Alex Thurgood 2011-11-13 01:26:20 UTC
(In reply to comment #24)
> I cannot reproduce the "table data window closes" behaviour with freshly
> compiled libreoffice-3-4 and native mysql driver. I only get the "opens behind"
> behaviour".

Hi Lionel,

My comment #12 was probably incorrect in that it appeared to me that the DataView window had disappeared because it positioned itself at the same coordinates behind the main window.

This is why I was led to believe that the DataView window closed itself after opening.

It was only when I opened several tables in a row that I noticed that the windows were superpositioned with a slight delta in the window coordinates.

Also, my comments aren't in chronological order because when I posted them, the bugzilla machines had their daylight saving time adjusted so my comments appeared to have been made an hour before they actually were, which of course screwed up the order of comments.

From my point of view, I don't think that the window closing behaviour exists.


Alex
Comment 26 Alex Thurgood 2011-11-13 01:28:09 UTC
(In reply to comment #22)


> I disabled the delay and confirmed it fixes (on master) the "table data view
> opened behind main application window" symptom. Could someone please check
> whether it also fixes (in 3.4.4rc2 with mysql, see comment 12) the "table data
> view closes after a second" symptom? I don't have access to that setup right
> now.

Sorry, I don't have a 3.4.x code tree... :-/

Alex
Comment 27 Lionel Elie Mamane 2011-11-13 05:21:58 UTC
(In reply to comment #25)
> (In reply to comment #24)
>> I cannot reproduce the "table data window closes" behaviour with freshly
>> compiled libreoffice-3-4 and native mysql driver. I only get the "opens behind"
>> behaviour".

> Also, my comments aren't in chronological order because when I posted them, the
> bugzilla machines had their daylight saving time adjusted (...)

I see; I took them in chronological order and the "last one" said "window closes".

> From my point of view, I don't think that the window closing behaviour exists.

Then -> duplicate

*** This bug has been marked as a duplicate of bug 35091 ***