Bug 42958 - Correctly import "center across selection" alignment settings.
Summary: Correctly import "center across selection" alignment settings.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Kohei Yoshida
QA Contact:
URL:
Whiteboard: target:3.5
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-11-15 14:14 UTC by Orion Poplawski
Modified: 2011-12-09 14:59 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
test xls document (127.50 KB, application/vnd.ms-excel)
2011-11-15 14:14 UTC, Orion Poplawski
Details
Screenshot of error message on file save under 3.4.4 and 3.5.0 (10.35 KB, image/png)
2011-12-06 21:48 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Orion Poplawski 2011-11-15 14:14:00 UTC
Created attachment 53585 [details]
test xls document

With LibreOffice 3.3.3.1/3.3.4.1 the attached file is opened properly.  With 3.4.3.2/3.4.4.1 it is not.

There are three main problems:

- Account in A9 is shifted to the left off page
- Month Total in A27 is shifted to the left off page
- The Signed: label in A29 is wrapped to two lines and truncated on top

When saved the incorrect formatting is preserved such that Excel will have the incorrect formatting.
Comment 1 Orion Poplawski 2011-11-15 14:16:57 UTC
Have not yet tested with earlier 3.4.X.
Comment 2 Kohei Yoshida 2011-12-06 21:05:59 UTC
Confirming.

Also, at this point we need to shift our focus toward 3.5, so I'll take a look at this for 3.5.
Comment 3 Pedro 2011-12-06 21:48:09 UTC
Created attachment 54170 [details]
Screenshot of error message on file save under 3.4.4 and 3.5.0

Cells A9+B9, A27+B27, A28+B28 and A29+B29 are merged. This shows up correctly in LO 3.3.4

Under LO 3.4.4 and 3.5.0 (Build ID: bee2841-43e9388-090bcba-d1db994-02ece8a) the merge property is lost and therefore the text in cell A appears to be shifted because it is centered on a single cell where it doesn't fit.

The loss of the merge information is indeed a regression.

Re-merging cells A and B for those lines is properly saved both under 3.4.4 and 3.5.0

Some information is lost (15kB out of 130kB) on Save but it is related to Basic Code (see attached image) so this is probably another bug.
Comment 4 Kohei Yoshida 2011-12-07 07:46:47 UTC
Fixed on libreoffice-3-5 and master.

http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=561f082041c5ede44d9443e534761a79953aedad

It was introduced due to DECLARE_LIST removal, which unfortunately changed the logic around this code.  Setting the logic back prior to the DECLARE_LIST removal fixes it.
Comment 6 Eike Rathke 2011-12-09 14:59:40 UTC
Just noticed (too late) that the commit's subject actually mentions bug 43308 instead of this one; don't worry, it's alright ;)