Bug 42968 - Send as... file vanishes when closing document
Summary: Send as... file vanishes when closing document
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-15 20:31 UTC by Arno Teigseth
Modified: 2012-04-25 09:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arno Teigseth 2011-11-15 20:31:10 UTC
This might be a feature. But to me it's a bug.

Reproduce:
1) Write something (writer, calc, whatever)
2) File -> send as... (PDF, excel, other)
3) The mail window pops up with an attachment. It can be opened. All well.
4) For some reason, close libreoffice entirely (haven't tested in windows, so I don't know about quickstart)
5) Try to open the attachment from the mail window again - it's gone.


This could be by design, 
-the attachment should probably be held file-locked by the mail program, and LO check if it's still in use before deleting it (preventing exit, or deciding to just leave the temp file undeleted)

-or, the temp attachment should not be deleted upon exit (not my favourite solution)

-or <your solution here>
Comment 1 Rainer Bielefeld Retired 2011-12-21 22:37:37 UTC
I am pretty sure that I saw an other report for exactly this problem few days ago, but I can not find it.
Comment 2 sasha.libreoffice 2012-03-07 02:49:21 UTC
@ Arno Teigseth
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
And which mail program used?
Comment 3 Arno Teigseth 2012-03-07 07:02:48 UTC
LibreOffice 3.5.0 
Build ID: 4036082-c4051ff-3b66bd0

that build was from git,

commit 251c24fed0fd34cec7e699a8af608748e5b9b4bf
Date:   Wed Feb 22 15:41:27 2012 -0500

Mail program: thunderbird 6.0 on linux mint 11


Still reproducible here with:
1) write "test doc" in a new doc in writer and send as email attachment
2) close writer (and maybe rest of LO windows?)
3) try opening the attachment in the compose mail. No luck, since the temp file was deleted when closing LO (I ASSume)


Should this be a thunderbird bug? That thunderbird should cache the attachment? I could agree to that if it's the intended design. 

Could be a good idea to cache anything handed to thunderbird from /tmp/ anyway.
Comment 4 sasha.libreoffice 2012-03-13 00:10:11 UTC
Thanks for additional testing.
I can not reproduce this problem on Fedora using Thunderbird
In LibreOffice 3.3.4 when I used File->Send as->Email, then saved this email on disk, then opened mail and saved attachment on disk. It saves ok.
In LibreOffice 3.5.0 writes: "LibreOffice was unable to find a working e-mail configuration". And nothing sends.

@ Arno Teigseth
This problem reproducible on another computer, OS, desktop?
This problem reproducible with another Email program?
If Thunderbird specific, try ask Thunderbird developers about this, may be they answer more quick than us
Comment 5 Xavi Escriche Galindo 2012-04-20 17:56:23 UTC
[Not reproducible] Works fine with "LibreOffice 3.5.2.2 - Mac OS X 10.5.8 (32bits) Catalan UI"
Comment 6 sasha.libreoffice 2012-04-20 22:54:25 UTC
It is Thunderbird specific bug. Reproducible when working with Thunderbird even without Libreoffice.
How to reproduce problem in Thunderbird:
1. create new letter
2. attach several big files so that sending will take several minutes
3. press "Send" button in Thunderbird
4. delete attached files from hard disk
Expected: files saved by Thunderbird in it's profile and will send correctly
Actually: appears error message after sending first file

This bug should send to Thunderbird developers
Comment 7 Arno Teigseth 2012-04-21 11:28:30 UTC
+1 for Thunderbird-dev. Many files are too temporary for the mail program to rely on them existing until the mail is sent.

Changing to INVALID.
Comment 8 sasha.libreoffice 2012-04-25 09:43:33 UTC
Changing status to NotOurBug because it is valid bug of Thunderbird