Download it now!
Bug 43071 - Labels for connectors are placed too far away from the lines they describe.
Summary: Labels for connectors are placed too far away from the lines they describe.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Connectors
  Show dependency treegraph
 
Reported: 2011-11-18 09:21 UTC by Johnny Baloney
Modified: 2018-06-16 14:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
labelled connectors in libre office draw (10.23 KB, application/vnd.oasis.opendocument.graphics)
2011-11-18 09:21 UTC, Johnny Baloney
Details
labelled connectors in libre office draw [gif] (35.45 KB, image/gif)
2011-11-18 09:22 UTC, Johnny Baloney
Details
labelled connectors in ms visio (43.50 KB, application/vnd.visio)
2011-11-18 09:23 UTC, Johnny Baloney
Details
labelled connectors in ms visio [gif] (34.19 KB, image/gif)
2011-11-18 09:23 UTC, Johnny Baloney
Details
resizing a shape (44.81 KB, image/gif)
2011-11-23 01:01 UTC, Johnny Baloney
Details
Example for workaround (15.23 KB, image/png)
2016-04-29 09:51 UTC, Heiko Tietze
Details
Import visio connectors fine in 6.0.4.2 (49.23 KB, image/png)
2018-06-16 14:28 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johnny Baloney 2011-11-18 09:21:44 UTC
Created attachment 53669 [details]
labelled connectors in libre office draw

Labels for connectors are placed too far away from the lines they describe.

See attachments for an example and a suggestion of how it should look. There is also an example made with MS Visio where it all works as expected.
Comment 1 Johnny Baloney 2011-11-18 09:22:44 UTC
Created attachment 53670 [details]
labelled connectors in libre office draw [gif]
Comment 2 Johnny Baloney 2011-11-18 09:23:13 UTC
Created attachment 53671 [details]
labelled connectors in ms visio
Comment 3 Johnny Baloney 2011-11-18 09:23:35 UTC
Created attachment 53672 [details]
labelled connectors in ms visio [gif]
Comment 4 Johnny Baloney 2011-11-23 01:01:58 UTC
Created attachment 53794 [details]
resizing a shape

This picture shows the moment when I grab one of the handles of a shape. At
that instant you can see "shadows" of the connectors giving a hint why the
labels are where they are.
Comment 5 csongor 2014-02-21 06:31:44 UTC
I proposed a possible way of solution for this issue. The point of my proposal is to attach text frames to certain glue points of connectors instead of using their own labels. See 75301 for more details.
Comment 6 Karl Behler 2014-09-04 07:34:54 UTC
See also bug 45028 describing problems when importing Visio connectors into Draw.
Comment 7 Johnny Baloney 2014-09-15 23:02:53 UTC
Still an issue in Version: 4.3.1.2.
Comment 8 QA Administrators 2015-10-14 19:58:00 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2016-01-30 13:22:55 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 9784ff3d878eaa21491fbd779e57d7d4710f5449
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-30_01:31:57
Locale: fi-FI (fi_FI)
Comment 10 Heiko Tietze 2016-04-29 09:51:44 UTC
Created attachment 124720 [details]
Example for workaround

Obviously the label is placed centered between start and end point. Although I agree with the use case and the idea to improve the placement, the current behavior is very predictable, and alternative positions might be wrong, for instance with curved connectors.

So isn't the workaround of adding line breaks (x) and spaces (.) better in terms of more flexibility? Visio's way of placing the label over the line without any transparency isn't that nice too.
Comment 11 QA Administrators 2017-09-01 11:20:50 UTC Comment hidden (obsolete)
Comment 12 Reuben 2017-11-06 06:45:02 UTC
Version: 5.4.1.2.0+
Build ID: 1:5.4.1-1
CPU threads: 2; OS: Linux 4.12; UI render: default; VCL: x11; 
Locale: en-AU (en_AU.UTF-8); Calc: group
Comment 13 Roman Kuznetsov 2018-06-16 14:28:07 UTC
Created attachment 142796 [details]
Import visio connectors fine in 6.0.4.2

views fine in

Version: 6.0.4.2 (x64)
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: ru-RU (ru_RU); Calc: CL
Comment 14 Roman Kuznetsov 2018-06-16 14:29:48 UTC
Status -> WFM