Bug 43289 - BUGZILLAASSISTANT does not work with Epiphany (webkit)
Summary: BUGZILLAASSISTANT does not work with Epiphany (webkit)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: needsDevEval, skillJavaScript, topicWeb
Depends on:
Blocks:
 
Reported: 2011-11-28 00:43 UTC by Lionel Elie Mamane
Modified: 2015-12-15 22:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (22.14 KB, image/png)
2011-11-28 00:43 UTC, Lionel Elie Mamane
Details
Epiphany screenshot 3.2.1 (102.45 KB, image/png)
2011-12-08 11:07 UTC, Julien Nabet
Details
screenshot of "scroll window within scroll window" (50.63 KB, image/png)
2012-02-23 14:27 UTC, Lionel Elie Mamane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2011-11-28 00:43:02 UTC
Created attachment 53893 [details]
screenshot

Using Epiphany 2.30.6-1 (Debian package), the bug submission assistant does not start. I get a mostly blank page, except for standard "LibreOffice website" widgets. Screenshot attached.
Comment 1 Julien Nabet 2011-12-08 11:07:35 UTC
Created attachment 54248 [details]
Epiphany screenshot 3.2.1

On Debian testing x86-32, I haven't a blank page since I have the steps at the left. The pb is that you can't sign on at all because the loading of the page doesn't succeed.

Here is Epiphany logs console :
(epiphany-browser:2116): Gtk-CRITICAL **: gtk_device_grab_add: assertion `GDK_IS_DEVICE (device)' failed

(epiphany-browser:2116): Gdk-CRITICAL **: gdk_device_grab: assertion `GDK_IS_DEVICE (device)' failed
** (epiphany-browser:2116): DEBUG: NP_Initialize
** (epiphany-browser:2116): DEBUG: NP_Initialize succeeded
** (epiphany-browser:2116): DEBUG: NP_Initialize
** (epiphany-browser:2116): DEBUG: NP_Initialize succeeded
** (epiphany-browser:2116): DEBUG: NP_Initialize
** (epiphany-browser:2116): DEBUG: NP_Initialize succeeded
** (epiphany-browser:2116): DEBUG: NP_Initialize
** (epiphany-browser:2116): DEBUG: NP_Initialize succeeded
** Message: console message: https://www.libreoffice.org/bugassistant/libreoffice/bug/jquery-1.6.2.js?1322470418 @7378: TypeError: 'undefined' is not an object (evaluating 'a.jquery')

Epiphany 3.2.1 (testing Debian package : Version: 0.7.0-5
Comment 2 Julien Nabet 2011-12-08 11:18:50 UTC
Perhaps it could be interesting to upgrade jquery to 1.7.1.
Of course, it would require tests.
Perhaps a test website exists ?
Comment 3 Petr Mladek 2011-12-13 11:33:09 UTC
See
http://wiki.documentfoundation.org/Bug_Submission_Assistant#Installation_and_maintainance
where to start debugging.
Comment 4 Julien Nabet 2012-02-23 13:25:25 UTC
I don't reproduce any more this problem with Epiphany (still 3.2.1). Apparently website has been updated.
Lionel, could you give it a new try please ?
Comment 5 Lionel Elie Mamane 2012-02-23 14:25:38 UTC
It basically works now.

I get an inconvenient "scroll window within scroll window" at the last step, but it seems to be functional.
Comment 6 Lionel Elie Mamane 2012-02-23 14:27:01 UTC
Created attachment 57556 [details]
screenshot of "scroll window within scroll window"
Comment 7 Petr Mladek 2012-02-24 08:58:26 UTC
Please, do not report many problems in one bug. This one is even worse because you started to solve completely different problem once the original one disappeared. It is confusing. Imagine people that read the subject and initial comment and stop reading because it is confusing. Some others might have more patience but they need to read 4 useless comments to find details about the real problem that still need to be solved.

I put back the original subject and close this bug as WORKSFORME.

Please, open new bug for the new problem with scrollbars.
Comment 8 Robinson Tryon (qubit) 2015-12-15 22:52:25 UTC
Migrating Whiteboard tags to Keywords: ( ProposedEasyHack -> needsDevEval, SkillJavaScript TopicWeb)
[NinjaEdit]