Bug 43291 - BUGZILLAASSISTANT better feedback on why submit is not allowed yet
Summary: BUGZILLAASSISTANT better feedback on why submit is not allowed yet
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: BSA
Keywords: needsDevEval, skillJavaScript, topicQA, topicWeb
Depends on:
Blocks:
 
Reported: 2011-11-28 00:53 UTC by Lionel Elie Mamane
Modified: 2015-12-15 23:47 UTC (History)
5 users (show)

See Also:


Attachments
screenshot - upper half of window (48.25 KB, image/png)
2011-11-28 00:53 UTC, Lionel Elie Mamane
Details
screenshot - lower half of window (26.27 KB, image/png)
2011-11-28 00:54 UTC, Lionel Elie Mamane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2011-11-28 00:53:42 UTC
Created attachment 53894 [details]
screenshot - upper half of window

Tried using the Bug Submission Assistant, using Debian Iceweasel version 3.5.16 (a rebranded version of Mozilla Firefox 3.5.16).

After answering all questions, I'm stuck on step 5. I've chosen component, subcomponent, and version. I've entered a subject and a long description. I've opened (in new tab or window) a few "Related bug reports" to check for duplicates.

But I see no "submit" button or similar.
Comment 1 Lionel Elie Mamane 2011-11-28 00:54:16 UTC
Created attachment 53895 [details]
screenshot - lower half of window
Comment 2 Rainer Bielefeld Retired 2011-11-28 22:31:43 UTC
Not a bug, it's a feature, but really worrying. The Submit button appears after you have typed at least 10 (?) characters into the Summary pane and THEN click something into the "Long description" (and have at least done a 1 character edit in "Long description".

I believe the idea was to prevent the reporter from accidently submitting before having finished.

Indeed that might be annoying because reporter wastes time searching for the 'Submit' button instead of simply completing the report. 

Suggestion for a solution:
1. Fields with missing contents should be marked light red background, 
   red border or similar (samd for 'Version' field if still 2choose one" 
   and reporter is astonished why not 'Summary' or 'Long description' 
   field appears)
2. The condition "Click into "Long description" after Summary is complete 
   should be removed
3. Help should be completed, no input should be without help
Comment 3 Lionel Elie Mamane 2011-11-28 23:04:49 UTC
(In reply to comment #2)
> Not a bug, it's a feature, but really worrying. The Submit button appears after
> you have typed at least 10 (?) characters into the Summary pane

And I had typed only three characters, OK.

> Suggestion for a solution:
> 1. Fields with missing contents should be marked light red background, 
>    red border or similar (samd for 'Version' field if still 2choose one" 
>    and reporter is astonished why not 'Summary' or 'Long description' 
>    field appears)
> 2. The condition "Click into "Long description" after Summary is complete 
>    should be removed

Rather than remove this condition completely I'd say:

Instead of "no submit button", have a greyed-out inoperative submit button *and* right next/under/before/... it, a text that says:

IF short description is too short THEN
  say "Subject: Please enter a short one-line summary of problem"
ELSE IF long description has not been edited THEN
  say "Long Description: Please explain your problem in detail and how to reproduce it"
ELSE
  enable submit button

If that's too hard to code, then the standard "submit button is there but does alert(error_message) if conditions not fulfilled" would be OK, too, and still better than the current.
Comment 4 Petr Mladek 2011-12-13 11:48:16 UTC
See
http://wiki.documentfoundation.org/Bug_Submission_Assistant#Installation_and_maintainance
where to start debugging.
Comment 5 Rob Snelders 2013-06-15 16:02:54 UTC
In the time the requirements are changed:
- minimal of 4 characters in subject
- long description needs to be changed

Also the box that isn't ok will be turned red. So I think the problem is solved.

Please reopen if you want more to change
Comment 6 Robinson Tryon (qubit) 2015-12-15 23:47:45 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval, SkillJavaScript TopicWeb TopicQA )
[NinjaEdit]