Download it now!
Bug 43340 - EDITING: cursor position invisible after adding a new slide via icon command
Summary: EDITING: cursor position invisible after adding a new slide via icon command
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Radek Doulik
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-29 09:06 UTC by Karl Zeiler
Modified: 2013-04-24 19:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
icon command via function bar (343.52 KB, image/jpeg)
2011-11-29 09:06 UTC, Karl Zeiler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Zeiler 2011-11-29 09:06:30 UTC
Created attachment 53953 [details]
icon command via function bar

A new usability feature in Impress implemented since LibO 3.3.0 and OOo 3.3.0 allows in an only step to add a new slide and select a layout via an icon command in the function bar (compare the attachment). 

When adding a new slide via the respective icon the blinking cursor position is displayed no more. Inserting text is possible. But editing is very annoying without displayed cursor position. After minimizing and maximizing the impress window the cursor position is visible again. And when adding a new slide, the cursor position is invisible again.

This bug occurs in LibO 3.4.4., 3.4.3, 3.3.4 … OOo 3.3.0 under all Windows versions –  may be under Linux and Mac too.

The other ways to add a slide via menu (Insert – in German: Einfügen) or context menu work normally – but without preselection of the layout.

Steps to reproduce the bug:
(1) Open a new Impress presentation.
(2) Click in a layout frame and insert any text.
Expected: the cursor position is blinking.
Result: the cursor position is blinking.

(3) Long click now the icon “Ad a new slide” (in German: Seite) and select any layout in one step.
(4) Click in the layout frame and insert any text in the second slide.
Expected: the cursor position is blinking.
Result: the cursor position is missing! Click in the first slide to edit any text: the cursor position is missing too.
Comment 1 Rainer Bielefeld Retired 2011-12-03 23:31:02 UTC
[Reproducible] with Server installation of  Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 130028f-b211287-090bcba-45cf606-05891e7]" Win-x86@9-Voreppe - 111130)

Steps to reproduce:
1. Open new Presentation with layout "Title slide"
2. Click into heading text box "Click to add a title"
   As expected Caret is flashing
3. Rightclick into only page in Slide pane
4. Context menu 'New slide'
   New slide with layout 'Title, content' will be created 
5. Click into heading text box "Click to add a title"
   As expected Caret is flashing
6. <Esc>
7. Standard Toolbar click/expand "Slide Button"
   Selector appears
8. Click 'Duplicate slide' at the bottom of the selector
   New duplicated slide with layout 'Title, content' will be created 
9. Click into heading text box "Click to add a title"
   As expected Caret is flashing
10. Standard Toolbar click/expand "Slide Button"
    Selector appears
11.  Select 'Title, content'
12. Click into heading text box "Click to add a title"
    Expected: Caret is flashing
    Actual: no Caret                                    !!!

Workaround: <alt+tab> to switch to an other program (no problem if it's also LibO) and again  <alt+tab> to switch back will make caret appear.
Reduced importance because of workaround.

I also see it with Portable 3.3.3 and OOo 3.3, so Problem is inherited from OOo

@Radek
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 2 A (Andy) 2013-04-23 19:38:07 UTC
for me not reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

@Rainer: Is this still reproducible for you?
Comment 3 Karl Zeiler 2013-04-23 22:40:34 UTC
Tested with

OpenOffice.org 3.4.1 (AOO341m1 - Build: 9593)
under Windows XP Pro:
Bug ist not reproducible.

LibO 3.6.6.2 (Build ID: f969faf)
under Windows 7/64 bit:
Bug is still reproducible.

Lib 4.0.2.2 (Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)
under Windows XP Pro:
Bug is not repruducible.

Regards
Karl
Comment 4 A (Andy) 2013-04-24 19:57:27 UTC
closed as Resolved

@Karl: Thank you very much for your fast reply.  If any issues come up again in future releases, please feel free to open it again.