Bug 43399 - Address data source wizard only uses evolution
Summary: Address data source wizard only uses evolution
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Lionel Elie Mamane
QA Contact:
URL:
Whiteboard: target:3.6.0 target:3.5.1 target:3.4.6
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-11-30 20:11 UTC by Allan Jacobs
Modified: 2012-02-14 05:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Allan Jacobs 2011-11-30 20:11:52 UTC
1. Create a writer document, say MailMergeTest.odt.
2. File > Wizards > Address Data Source.
3. There is only one choice for address book type for my operating system: Other external data source.  Choose it.
4. Click Next>>

An error dialog reading "The connection to the external data source could not be established.  No SDBC driver was found for the given URL.

5. Click More

The error dialog that appears reads says that this is "SQL Status: HY000".

6. OK
7. OK
8. Cancel

The expectation is that Next>> will allow us to advance to do "Connection Settings" and define the database type as "Spreadsheet".
Comment 1 bash.vi 2012-01-17 00:30:15 UTC
I can confirm this bug on Linux Mint 12 x86_64 and Gentoo Linux x86_64 (Libreoffice 3.4.3) (Java useflag disabled).
I get exactly the behavior described here. On both systems. If it was only on Gentoo, I would have thought it was because of my useflags. But I've seen it on Linux Mint too.

There seems to be a similar problem in Ubuntu 32bit: http://lists.freedesktop.org/archives/libreoffice-bugs/2011-December/027978.html
Comment 2 bash.vi 2012-01-18 13:35:57 UTC
So I reemerge (or upgraded) LibreOffice 3.4 to 3.4.5, now with Java useflag enabled. Same effect.
I'm using Sun Java 1.6.
Comment 3 sasha.libreoffice 2012-02-13 06:08:06 UTC
reproduced in 3.6.0 master on Fedora 64 bit
but not reproduced in 3.3.4, therefore regression
Comment 4 sasha.libreoffice 2012-02-13 06:09:11 UTC
@ Lionel
Please, take look at this
Comment 5 Lionel Elie Mamane 2012-02-13 06:16:39 UTC
When you get the "No SDBC driver was found for the given URL" error message, please click "more". In the left part of the window (error list), you should have two entries. The second entry says something along the lines of: "A connection for the following URL was requested "sdbc:XXXXX". What comes instead of the XXX for you?

Since it works in 3.3.4, what are the steps in the wizard called in 3.3.4? I get (in 3.5):

 Address Book Type
 Table Selection
 Field Assignment
 Data Source Type

Frpom the descroption, I get the impression that there should be an extra step?
Comment 6 Lionel Elie Mamane 2012-02-13 06:18:17 UTC
Hmm... I get the same problem for *any* choice in step 1. Do any of the other choices (LDAP, Mozilla, Thunderbird, ...) work for anybody with LibO 3.4 or 3.5?
Comment 7 sasha.libreoffice 2012-02-13 06:21:15 UTC
In 3.6.0 master in only one choice: Other external data sources

Error text:

SQL Status: HY000

The connection to the external data source could not be established. No SDBC driver was found for the given URL.

Information text:
A connection for the following URL was requested "sdbc:address:evolution:local".
Comment 8 sasha.libreoffice 2012-02-13 06:23:58 UTC
3.5.0 rc 3 has choices: Mozilla/Thunderbird/LDAP/Other
If select Other, appears the same problem
Comment 9 Lionel Elie Mamane 2012-02-13 06:26:19 UTC
(In reply to comment #8)
> 3.5.0 rc 3 has choices: Mozilla/Thunderbird/LDAP/Other
> If select Other, appears the same problem

And if you select "LDAP" or "Thunderbird" or "Mozilla"?
Comment 10 sasha.libreoffice 2012-02-13 06:32:11 UTC
In 3.5.0 the same problem with Mozilla/Thunderbird/LDAP
but my be so should be with Mozilla/Thunderbird/LDAP
in 3.3.4 they propose select some file
Comment 11 Lionel Elie Mamane 2012-02-13 06:38:14 UTC
OK, then the problem is wider than current summary. Correcting summary.

Basically, independently of any choice one makes in step 1, it always tries to get data from evolution instead of from the source chosen.
Comment 12 Lionel Elie Mamane 2012-02-13 09:14:58 UTC
Fixed in master: http://cgit.freedesktop.org/libreoffice/core/commit/?id=8eb33ee13519bd3059cdb2019ef843fbb9a7fbd7

For 3.5.1 and 3.4.6, pending review.
Comment 13 sasha.libreoffice 2012-02-13 22:02:19 UTC
Thanks
Comment 14 Andras Timar 2012-02-14 05:21:10 UTC
patch was pushed to libreoffice-3-5 and libreoffice-3-4