Bug 43469 - unable to import readline library from libreoffice's embedded python on RHEL5.5
Summary: unable to import readline library from libreoffice's embedded python on RHEL5.5
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-02 06:56 UTC by Piotr Wilkosz
Modified: 2012-09-13 10:01 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Wilkosz 2011-12-02 06:56:09 UTC
[wilkpio@lx4338 ~]$ /opt/libreoffice3.4/program/python
Python 2.6.1 (r261:67515, Nov  1 2011, 18:48:17) 
[GCC 4.2.4] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import readline
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: libreadline.so.4: cannot open shared object file: No such file or directory
>>> 
KeyboardInterrupt
>>> 
[wilkpio@lx4338 ~]$ 

The problem is that libreadline.so.4 required  by readline.so can not be found. 

[wilkpio@lx4338 ~]$ ldd /opt/libreoffice3.4/basis-link/program/python-core-2.6.1/lib/lib-dynload/readline.so
ldd: warning: you do not have execution permission for `/opt/libreoffice3.4/basis-link/program/python-core-2.6.1/lib/lib-dynload/readline.so'
        libreadline.so.4 => not found
        libncursesw.so.5 => /usr/lib64/libncursesw.so.5 (0x00002b6fd5cd9000)
        libpython2.6.so => /usr/lib64/libpython2.6.so (0x00002b6fd5f3e000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002b6fd62e8000)
        libc.so.6 => /lib64/libc.so.6 (0x00002b6fd6503000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002b6fd685b000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00002b6fd6a60000)
        libm.so.6 => /lib64/libm.so.6 (0x00002b6fd6c63000)
        /lib64/ld-linux-x86-64.so.2 (0x000000344d800000)


Could be fixed by providing copy of libreadline.so.4 (not present in RHEL5.5) in /opt/libreoffice3.4/basis3.4/program dir.

Thanks,
Piotr
Comment 1 Mas 2012-09-13 10:01:35 UTC
You will need to update readline on your local system. This can be done using 

yum install readline

or 
rpm -Uvh readline-version.rpm